Symptômes
Après avoir appliqué SQL Server mise à jour cumulative 2019 CU2/CU3/CU4 ou SQL Server mise à jour cumulative 2017 CU19/CU20/CU21, lorsque vous essayez de sauvegarder la base de données à l’aide de VDI sur SQL Server sur Linux, vous pouvez remarquer que la sauvegarde échoue avec le message d’erreur suivant :
Ouverture de l’appareil.
VDS ::OpenDevice échoue : x80770004
Msg 18210, Level 16, State 1, Server <ServerName>, Line LineNumber
BackupVirtualDeviceSet ::AllocateBuffer : échec sur l’appareil de sauvegarde '6effc98c-5db7-470f-a5f9-468c6ce0736b'. Erreur de système d’exploitation 995(L’opération d’E/S a été abandonnée en raison de la sortie d’un thread ou d’une demande d’application.).
Msg 3013, Niveau 16, État 1, ServerName><, Ligne LineNumber
La base de données de sauvegarde se termine anormalement.
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Résolution
Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2019
- Dernière mise à jour cumulative pour SQL Server 2017
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.