KB4530955 - CORRECTIF : l’erreur 18456 se produit lorsque vous exécutez des requêtes DMV sur le instance SQL Server 2019 ou 2017 après la reconstruction des bases de données système

S’applique à
SQL Server 2017 Developer Linux SQL Server 2017 Enterprise Core on Linux SQL Server 2017 Enterprise on Linux SQL Server 2017 Standard on Linux SQL Server 2017 Developer on Windows SQL Server 2017 Enterprise on Windows SQL Server 2017 Enterprise Core on Windows SQL Server 2017 Standard on Windows SQL Server 2019 on Windows SQL Server 2019 on Linux

Symptômes

Lorsque vous utilisez Microsoft SQL Server 2019 ou 2017, vous remarquez que lorsque vous reconstruisez des bases de données système, cette action supprime la connexion pour le Programme d’amélioration de l’expérience utilisateur (CEIP) SQL Server.

En outre, de nombreuses instances de SQL Server’erreur 18456 peuvent être générées lorsque vous essayez d’exécuter des requêtes DMV (Dynamic Management View) sur le SQL Server instance une fois la reconstruction terminée.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.