Symptômes
Supposons que vous disposez de bases de données activées pour Transparent Data Encryption (TDE) dans Microsoft SQL Server. Toute sauvegarde compressée TDE à une seule bande effectuée entre SQL Server 2016 Service Pack 2 (SP2) et SQL Server mise à jour cumulative 4 (CU4) SP2 ne peut pas être restaurée dans la mise à jour cumulative 8 (CU8) de SQL Server 2016 SP2. L’échec de la restauration provoque une erreur semblable à la suivante :
Msg 3203, Niveau 16, État 1, Ligne LineNumber
Échec de la lecture de « FilePath\FileName » : 1101(Un accès à bande a atteint une marque de fichier.)
Msg 3013, Niveau 16, État 1, Ligne LineNumber
La base de données de restauration se termine anormalement.
DateTime spid56 Starting up database 'DatabaseName'.
DateTime spid56 La base de données « DatabaseName » est marquée comme RESTAURATION et se trouve dans un état qui ne permet pas l’exécution de la restauration.
DateTime Erreur de sauvegarde : 18210, Gravité : 16, État : 1.
DateTime Backup BackupIoRequest ::ReportIoError : échec de lecture sur le périphérique de sauvegarde 'FilePath\FileName'. Erreur de système d’exploitation 1101 (un accès sur bande a atteint une marque de fichier.).
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Résolution
Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.