KB2907283 - FIX: errore "Timeout scaduto" quando si usa PowerShell per eseguire il backup o il ripristino di un database di grandi dimensioni in SQL Server 2012 o SQL Server 2014

Si applica a
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Express SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Sintomi

In Microsoft SQL Server 2012 o SQL Server 2014 si prova a eseguire il backup di un database di grandi dimensioni usando il cmdlet Backup-SqlDatabase oppure si prova a ripristinare un database di grandi dimensioni usando il cmdlet Restore-SqlDatabase. In questo caso, dopo 10 minuti si verifica un errore di timeout. Viene inoltre visualizzato il seguente messaggio di errore in Windows PowerShell:

Nota

Timeout scaduto. Il periodo di timeout è trascorso prima del completamento dell'operazione o il server non risponde.

Causa

Il problema si verifica perché i cmdlet Backup-SqlDatabase e Restore-SqlDatabase utilizzano 600 secondi come valore di timeout predefinito.

Risoluzione

Il problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server.

Aggiornamento cumulativo 1 per SQL Server 2014 /it-it/help/2931693

Aggiornamento cumulativo 8 per SQL Server 2012 SP1 /it-IT/help/2917531

Informazioni sugli aggiornamenti cumulativi per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

      

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".