KB2973561 - FIX: Errore durante l'inserimento di un record in una tabella FileTable o FILESTREAM in SQL Server 2012 o SQL Server 2014

Si applica a
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Sintomi

Si consideri lo scenario seguente:

  • È presente una tabella FileTable o FILESTREAM in Microsoft SQL Server 2012 o SQL Server 2014.
  • Hai impostato MAXSIZE dei dati FILESTREAM su UNLIMITED.
  • Si inserisce un record nella tabella FileTable quando le dimensioni del contenitore FILESTREAM raggiungono i 32 terabyte (TB).

In questo scenario, l'inserimento non riesce e viene visualizzato il seguente errore:

Nota

errore 1105: Impossibile allocare spazio per l'oggetto '<object_name>' nel database 'database >'<perché il filegroup '<filestream_filegroup>' è pieno.

Risoluzione

Il problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server.
Dopo aver applicato la correzione, quando il contenitore FILESTREAM MAXSIZE è impostato su UNLIMITED, continua a crescere fino a quando il disco è pieno.

Aggiornamento cumulativo 2 per SQL Server 2012 SP2 /it-IT/help/2983175

Aggiornamento cumulativo 3 per SQL Server 2014 /it-it/help/2984923

Aggiornamento cumulativo 11 per SQL Server 2012 SP1 /it-it/help/2975396

Informazioni sugli aggiornamenti cumulativi per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

      

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".