KB2927779 - FIX: Il database mostra lo stato "ripristino in sospeso" quando si usa TDE con il provider EKM in SQL Server 2012 o SQL Server 2014

Si applica a
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Sintomi

Si supponga di disporre di database TDE (Transparent Data Encryption) crittografati utilizzando il provider EKM (Extensible Key Management) in Microsoft SQL Server 2012 o SQL Server 2014. Quando si esegue una query di inserimento con carico elevato in una connessione di rete instabile, il database TDE non è più disponibile e mostra lo stato "Ripristino in sospeso". Vengono visualizzati i seguenti errori:

Nota

<Data><Ora> spid1s Impossibile aprire la sessione per il provider di crittografia '<Nome provider> EKM'. Codice di errore del provider: 5. (Errore di autenticazione - consultare il provider EKM per i dettagli)
<Data><Ora> spid125 Errore: 9001, gravità: 21, stato: 1.
<Data><Ora> spid125 Il log per il database '<DB name>' non è disponibile. Controlla il registro eventi per i messaggi di errore correlati. Risolvere eventuali errori e riavviare il database.
<Data><Ora> spid125 Durante l'annullamento di un'operazione registrata nel database 'DB name>', si è verificato un errore nell'ID< record di log (1183:136:350). In genere, l'errore specifico è registrato in precedenza come errore nel servizio Registro eventi di Windows. Ripristinare il database o il file da un backup o ripristinare il database.
<Data><Ora> Il nome> del database spid62 è < stato arrestato a causa dell'errore 3314 nella routine 'XdesRMReadWrite::RollbackToLsn'. Il riavvio per i database non snapshot verrà tentato dopo l'interruzione di tutte le connessioni al database.

      

Risoluzione

Dopo aver applicato la correzione, il database TDE tenterà di usare le chiavi di crittografia del database memorizzate nella cache durante le interruzioni di rete. In questo modo si impedisce l'arresto.
Il comportamento da progettazione è stato modificato nell'aggiornamento cumulativo seguente di SQL Server.

Aggiornamento cumulativo 1 per SQL Server 2014 /it-it/help/2931693

Aggiornamento cumulativo 9 per SQL Server 2012 SP1 /it-it/help/2931078

Informazioni sugli aggiornamenti cumulativi per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server: