KB3052404 - FIX: non è possibile utilizzare il protocollo Transport Layer Security versione 1.2 per connettersi a un server in esecuzione SQL Server 2014 o SQL Server 2012

Si applica a
SQL Server 2014 Business Intelligence - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Express - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Web - duplicate (do not use) SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard

Sintomi

Non è possibile connettersi a un server che esegue Microsoft SQL Server 2014 o SQL Server 2012 utilizzando il protocollo TLS (Transport Layer Security) versione 1.2. Nel log degli errori di SQL Server viene inoltre registrato il messaggio di errore seguente:

Nota

Inizializzazione TDSSNIClient non riuscita con 0x80090331 errore, codice di stato 0x80. Motivo: impossibile inizializzare il supporto SSL. Il client e il server non possono comunicare, perché non possiedono un algoritmo comune.

      

Risoluzione

Questo problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server.

Aggiornamento cumulativo 12 per SQL Server 2014
        
         Aggiornamento cumulativo 5 per SQL Server 2014 SP1
        
         Aggiornamento cumulativo 10 per SQL Server 2012 SP2
        
         Aggiornamento cumulativo 1 per SQL Server 2012 SP3 Nota: questo aggiornamento aggiunge il supporto per il protocollo TLS (Transport Layer Security) versione 1.2 a SQL Server 2014 e al driver Microsoft ODBC per SQL Server.

Informazioni sugli aggiornamenti cumulativi per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

      

Nota: È possibile trovare informazioni sulle build più recenti di SQL Server da Dove trovare informazioni sulle build più recenti di SQL Server.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.