Sintomi
Si supponga di usare Microsoft SQL Server 2012 o SQL Server 2014. Quando si esegue una query per aggiornare una tabella che contiene una colonna calcolata XML, si verifica un'eccezione di violazione di accesso. La query funziona correttamente dopo aver eliminato i vincoli della tabella. Una violazione di accesso si verifica di nuovo quando si tenta di aggiungere nuovamente i vincoli. Viene visualizzato l'errore seguente:
Nota
Si è verificato un errore grave nel comando corrente. I risultati, se presenti, devono essere scartati.
Causa
Un oggetto metadati interno viene reimpostato in modo errato. Questo porta all'eccezione.
Risoluzione
Il problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server.
Aggiornamento cumulativo 1 per SQL Server 2014 /it-it/help/2931693
Aggiornamento cumulativo 9 per SQL Server 2012 SP1 /it-it/help/2931078
Informazioni sugli aggiornamenti cumulativi per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
- Aggiornamento cumulativo più recente per SQL Server 2014
- Aggiornamento cumulativo più recente per SQL Server 2012 SP1
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".