Sintomi
Si supponga di avere una tabella che partecipa a una replica transazionale peer-to-peer di Microsoft SQL Server 2012 o SQL Server 2014 e che la tabella contenga un numero elevato di colonne. Quando si verifica un conflitto per questa tabella, è possibile che l'agente di distribuzione non funzioni e viene visualizzato il messaggio di errore seguente:
Nota
I dati stringa o binari verrebbero troncati. (Fonte: MSSQLServer, numero di errore: 8152)
Risoluzione
Il problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server:
- Aggiornamento cumulativo 3 per SQL Server 2014 SP1
- Aggiornamento cumulativo 10 per SQL Server 2014
- Aggiornamento cumulativo 8 per SQL Server 2012 SP2
Consiglio: installare l'aggiornamento cumulativo più recente per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. È consigliabile scaricare e installare gli aggiornamenti cumulativi più recenti per SQL Server:
- Aggiornamento cumulativo più recente per SQL Server 2014 SP1
- Aggiornamento cumulativo più recente per SQL Server 2014
- Aggiornamento cumulativo più recente per SQL Server 2012 SP2
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".