KB3090049 - FIX: Impossibile creare il certificato Transparent Data Encryption in SQL Server 2012 o SQL Server 2014

Si applica a
SQL Server 2012 Enterprise SQL Server 2012 Developer SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Sintomi

Questo problema si verifica quando si utilizza un certificato il cui numero di serie è maggiore di 16 byte. Quando si verifica questo problema, viene visualizzato il messaggio di errore seguente:

Nota

Messaggio 15297, livello 16, stato 56, riga 1
 I dati del certificato, della chiave asimmetrica o della chiave privata non sono validi.

Risoluzione

Il problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server:

Consiglio: installare l'aggiornamento cumulativo più recente per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. È consigliabile scaricare e installare gli aggiornamenti cumulativi più recenti per SQL Server:

      

        
Nota Dopo aver installato questo aggiornamento, è possibile creare il certificato anche se il suo numero di serie è maggiore di 16 byte senza ricevere alcun messaggio di errore. Tuttavia, il numero di serie verrà troncato a 16 byte quando viene salvato nella colonna cert_serial_number nella visualizzazione del catalogo sys.certificates. Il troncamento viene eseguito solo nella visualizzazione catalogo. Pertanto, il certificato conserva ancora la lunghezza originale per il suo numero di serie.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".