KB3023634 - FIX: L'errore di conversione si verifica quando si utilizza una regola di business in MDS SQL Server 2012 o SQL Server 2014

Si applica a
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Sintomi

Si consideri lo scenario seguente:

  • È possibile creare una regola aziendale che verifica l'eventuale presenza di un valore vuoto in un attributo numerico in Microsoft SQL Server 2012 Master Data Services (MDS).
  • La regola di business viene salvata e pubblicata.
  • Aprire l'entità in MDS Explorer ed eseguire la regola di business per convalidare i membri dell'entità.

In questo caso, viene visualizzato il seguente messaggio di errore:

Nota

8114: Errore durante la conversione del tipo di dati nvarchar in numerico. Il numero di transazioni dopo l'esecuzione indica un numero non corrispondente di istruzioni BEGIN e COMMIT. Conteggio precedente = 0, conteggio corrente = 1.

Nota: questo problema si verifica anche in SQL Server 2014 MDS che ha applicato CU3 o versioni successive. Ad esempio, quando si esegue una regola aziendale in MDS che controlla se un attributo di data è vuoto, viene visualizzato il messaggio di errore seguente:

Nota

Errore durante la conversione del tipo di dati nvarchar in datetime

      

Risoluzione

Il problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server.

Aggiornamento cumulativo 6 per SQL Server 2014 /it-it/help/3031047

Aggiornamento cumulativo 4 per SQL Server 2012 SP2 /it-IT/help/3007556

Aggiornamento cumulativo 14 per SQL Server 2012 SP1 /it-IT/help/3023636

Informazioni sugli aggiornamenti cumulativi per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

      

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".