Sintomi
Si supponga di avere un database che contiene una tabella partizionata in Microsoft SQL Server 2014 o SQL Server 2012. Le partizioni della tabella sono mappate a filegroup diversi e alcuni mapping di filegroup non sono validi. Quando si esegue l'istruzione DBCC CHECKDB, i filegroup non validi vengono rilevati e segnalati nei risultati:
Nota
Impossibile elaborare l'indice <IndexName> della tabella <TableName> perché filegroup (FileGroup ID<, FileGroupNumber>) non è valido.
Tuttavia, la sezione di riepilogo non segnala errori di allocazione o coerenza.
Risoluzione
Il problema è stato risolto per la prima volta negli aggiornamenti cumulativi seguenti di SQL Server:
- Aggiornamento cumulativo 4 per SQL Server 2012 SP3
- Aggiornamento cumulativo 3 per SQL Server 2014 SP1
Consiglio: installare l'aggiornamento cumulativo più recente per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. È consigliabile scaricare e installare gli aggiornamenti cumulativi più recenti per SQL Server:
- Aggiornamento cumulativo più recente per SQL Server 2012 SP3
- Aggiornamento cumulativo più recente per SQL Server 2014 SP1
Nota: questa correzione corregge solo il comportamento di segnalazione DBCC CHECKDB in modo che i filegroup non validi vengano segnalati nel riepilogo DBCC CHECKDB come errori di coerenza. La correzione non corregge gli errori di filegroup o di coerenza non validi e si consiglia di ripristinare il database dall'ultimo backup valido noto per correggere il danneggiamento.
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".