データ ビジュアライザーの図面を作成する

Excel ブックから、詳細で洗練された Visio フローチャートを自動的に作成しますか? これを行うには、データ ビジュアライザー テンプレートを使用します。 各テンプレートには、Visio でプロセス データをフローチャートに変換するために使用される Excel ワークブックが関連付けられています。 また、独自のカスタム Excel テンプレートを使用して、[データからの図の作成] ウィザードで Excel データを図形にマップし、図を自動的に作成することもできます。 Visio の図形データに変換されるデータ列を Excel に追加することもできます。

また、Visio では、Visio ダイアグラムと Excel ブックの間で 2 つの同期方法がサポートされます。 Excel のデータを編集して Visio からダイアグラムを更新し、フロー チャートを作成できるだけでなく、Visio のダイアグラムを変更して、ダイアグラムから Excel データを更新することもできます。 

データ ビジュアライザーの概要を示すスクリーンショット

sデータ ビジュアライザー テンプレートを使用する機能は、Visio Plan 2 でのみ利用できます。 使用している Visio のバージョンがわからない場合は、[ファイル] >[アカウント]>[Visio について] を選択します。 Visio のサブスクリプション バージョンの詳細については、「Visio Plan 2」を参照してください。

データ ビジュアライザーのテンプレートが表示されない場合、または作業を開始するにあたって質問がある場合は、「Data Visualizer frequently asked questions」 (データ ビジュアライザーについてよく寄せられる質問) を参照してください。

注

この機能を使用するには、 Microsoft 365 サブスクリプションが必要です。 Microsoft 365 サブスクリプションをお持ちの場合は、最新バージョンの Office をインストールしているかどうか確認してください。 Microsoft 365 の更新プロセスを管理している IT プロフェッショナルである場合は、「チャネル リリース」ページをチェックして、各チャネルで提供される更新プログラムを確認してください。

この記事の内容

データ ビジュアライザーのダイアグラムを作成する

始める前に

自分のアイデアを寄せ集めて、紙の上に、または手描き入力で下書きして形にします。 この大まかな下書きを作成することで、すぐに作業を開始し、次の手順をスムーズに実行することができます。

データ ビジュアライザーのダイアグラムを作成する場合、Excel と Visio で同時に作業を行うことができます。 操作しやすくするために、Windows デバイス上の 2 つのウィンドウで、またはマルチ モニター環境で作業することをお勧めします。 Excel での作業内容と Visio での作業内容を視覚的に比較すれば、自分が行おうとしていることを確認するのに役立ちます。

推奨事項: この Microsoft Office ビデオをご覧になり、実際の動作をご覧ください。 データ ビジュアライザー: デモ。

ステージ 1: データ ビジュアライザーのテンプレートを選択する

  1. Visio を開くか、図面を編集している場合は、[ ファイル>新規] を選択します。

  2. [テンプレート] を選択します。

    テンプレートのスクリーンショット

  3. [フローチャート] を選択します。

    フローチャート コマンドのスクリーンショット

  4. [基本フローチャート - データ ビジュアライザー]、[部門連係フローチャート - データ ビジュアライザー]、または [監査図 - データ ビジュアライザー] を選択します。

    データ ビジュアライザー テンプレートのスクリーンショット

    データ ビジュアライザー テンプレートの左上隅には Excel アイコンがあります。

フロー チャートとその図形の詳細については、「基本フローチャートを作成する」と「部門連係フローチャートを作成する」を参照してください。

ステージ 2: Excel ブックを作成する

  1. テンプレートのプレビューで、[データの Excel テンプレート] を選択します。

    Excel データ テンプレートのスクリーンショット
     
    メモ: この記事で使用しているのと同じサンプル Excel テンプレートを参照として使用する場合は、次のリンクからダウンロードできます。

  2. [ファイル>保存] を選択し、コンピューター、ネットワーク サーバー、または SharePoint ドキュメント ライブラリを指定して、ファイル名を入力して、[保存] を選択します。

  3. 新しいワークシートを追加するには、ブックの下部にある [ 新しいシート]ボタン を選択します。

  4. Excel の表を作成します。 Excel の表の使い方の詳細については、「Excel の表の概要」、「Excel テーブルを作成または削除する」、および「行や列を追加または削除してテーブルのサイズを変更する」を参照してください。

  5. Visio ダイアグラムを作成するために使用する行と列を表に追加します。 Excel の表の列見出しと値には特定の要件が適用されます。 「Excel の列で Visio フローチャートのコンポーネントを操作する方法」セクションで視覚的に説明します。

ステージ 3: その他の図形データを Excel の表に追加する (省略可能)

  1. Excel テンプレートの [プロセス マップ] タブを調べます。 Excel の表の列は、青と緑で色付けされています。 色は、列の間の違いを視覚的に認識する手がかりとなります。
    青色の列は、Visio のダイアグラムでフローチャートを作成する場合に使用されます。 すべての列はまた、図形データとして追加されます。
  2. その他の図形データを追加するには、Excel の表に 1 つまたは複数の列を追加します。
    緑色の列は、各図形に追加することができる図形データを示します。 任意の数の列を追加することができます。 既定では、図形データはデータ グラフィックを追加しない限り、ダイアグラムには表示されません。 Visio 図面で図形データを表示するには、[ データ>図形データ ウィンドウ] を選択します。 図形データおよびデータ グラフィックの詳細については、「図形にデータを追加する」と「データ グラフィックの概要」を参照してください。

ステージ 4: ウィザードを使用して Visio ダイアグラムを作成する

  1. Visio に戻り、テンプレートのプレビューで単位を選択し、[作成] を選択します。

  2. [データからの図の作成] ウィザードの最初のページで、次の操作を行います。

    1. [ データから作成する図面] で、テンプレートを選択します。 [基本フローチャート]、[部門 連系フローチャート (横方向]、または [ 部門間フローチャート (縦方向)] を選択します。
    2. [Excel ブックの選択] で、最近使用したほとんどのブックを含む一覧からブックを選択するか、[参照] を選択してステージ 2 で作成したブックを検索します。
    3. [ブックのテーブルまたはユーザー指定の範囲を選択] で、Excel プロセス データを含む表を選択します。
    4. [完了] をクリックします。 これにより、ウィザードの他のページに Visio が入力するすべての既定値が受け入れられます。

結果として、コンテナー内でダイアグラムが自動的に作成されます。 追加の Visio ページは、フロー チャートのサイズに応じて追加されます。

ステージ 5: Visio のダイアグラムを保存する

  • [ファイル>保存] を選択し、場所を検索してファイル名を入力し、[保存] を選択します。

Excel ファイルと Visio ファイルは、連携しているので同じ場所に保存することをお勧めします。

ステージ 6:データとダイアグラムを同期する

データ ビジュアライザーでダイアグラムを作成した後で、その変更が必要となる場合もあります。 Visio では、ソース データとダイアグラムの間で双方向同期をサポートします。

ヒント 作業を完了したら、両方のファイルを同期し、最新の状態に保ちます。 ダイアグラムのコンテンツを変更する場合は、Excel データを更新します。

Excel のデータを変更して、ダイアグラムを更新するには

  1. Excel の表のソース データに変更を加えます。 行を追加、更新、または削除することができます。
  2. Excel ブックを保存します。
  3. Visio で、図面のコンテナーを選択して、リボンの [データ ツールのデザイン ] タブを有効にし、[ 図の更新] を選択します。

この結果、Excel ブックで行った変更は、Visio のダイアグラムに表示されます。 次の点に注意してください。

  • ダイアグラムに更新後に失われる可能性のある変更を加えた場合、Visio に [競合するダイアグラムの更新] ダイアログ ボックスが表示されます。
  • リフレッシュを行った場合にのみ、コンテナー内の図形と接続に変更が加えられます。
  • コンテナー内の図形またはコネクタに加えた書式に関する変更は保持されます。
  • ダイアグラムの図形とコネクタ ラインはすべてコンテナー内に保持してください。 ページ上のその他のオブジェクトのうち、コンテナーの外側にあるものは、影響を受けません。 詳細については、「コンテナーやリストを使用して、図の構造を明らかにする」を参照してください。

ダイアグラムのコンテンツを変更して、Excel のデータを更新するには

  1. Visio の図面を変更します。 図形とコネクタを追加、更新、または削除できます。
  2. Excel ブックがデスクトップ コンピューターまたはネットワーク ファイル サーバー上にある場合は、ブックが保存されて閉じられていることを確認します。
  3. ダイアグラム コンテナーをクリックし、リボンの [データ ツール] の [デザイン] タブを有効にして、[ソース データの更新] を選択します。

その結果、Visio 図面で行った変更が Excel ブックでも更新されます。 Excel でデータが失われる可能性がある場合、Visio に [競合するソース データの更新] ダイアログ ボックスが表示されます。 問題を回避するには、次のベスト プラクティスを使用します。

  • 変更を上書きする前に、Excel データのバックアップを保存します。
  • Excel ブックで、ユーザー設定の範囲ではなく、データ ソースとして Excel の表を使用します。 [ソース データの更新] ダイアログ ボックスで [上書き] を選択すると、Visio でユーザー設定の範囲が Excel の表に変換されます。
  • Excel データ ソースに数式を使用しないでください。 [ソース データの更新] ダイアログ ボックスで [上書き] を選択すると、Visio で数式が数式の結果に変換されます。
  • データ列が関数とフェーズにマップされる [データからダイアグラムを作成] ウィザードのオプションを使用して図を作成しました: マッピング>その他のオプション>作成するデータから列値の順序を保持する>関数またはスイム レーンの選択、またはフェーズまたはタイムラインの選択。 この場合、Visio では図形間の接続を表すためにデータに追加の列が必要になります。 [ソース データの更新] ダイアログ ボックスで [上書き] を選択すると、追加の列が追加されます。
  • Excel のデータ値の順序に基づいて、スイムレーンとフェーズの両方を含む部門連係フローチャートを作成しました。 データ列がプロセスステップとアクティビティに接続されている「データからのダイアグラムの作成」ウィザードで、次のオプションを使用してダイアグラムを作成しました:マッピング>プロセスステップ/アクティビティを順次接続する方法の指定>接続。 この場合、Visio では図形間の接続を表すためにデータに追加の列が必要になります。 図のスイムレーンまたはフェーズの順序を変更すると、データ ソース内の順序が変更されます。 [ソース データの更新] ダイアログ ボックスで [上書き] を選択すると、図のスイムレーンとフェーズは、Excel ブック内のデータの順序に従わなくなります。

ステージ 7: Excel の表と Visio のダイアグラムとのやり取りをカスタマイズする (省略可能)

データ ビジュアライザーでのダイアグラムの作成をカスタマイズしたい場合があります。 たとえば、組織の標準に準拠した別の図形を使用したり、Excel の表内の別の列名にマッピングしたりする場合があります。

  1. [ 作成 ] を選択して [データからの図の作成 ] ウィザードに入り、最初のページで値を入力した後 (ステージ 4 を参照)、次 へ または [戻る] を選択してウィザードの各ページを表示します。
  2. ページ上の各オプションをカスタマイズする方法の詳細を確認するには、[ヘルプ (?)] を選択してください。 詳細については、「Use the Create Diagram from Data wizard」 ([データからの図の作成] ウィザードを使用する) を参照してください。

ページの先頭へ

Excel の列で Visio フローチャートのコンポーネントを操作する方法

Excel の各列を使用して Visio フローチャートを作成する方法を理解するには、次の画像付きチュートリアルを参照してください。

Excel テーブルのさまざまな列を説明するために、以下に一連の "タブ" (「ID」、「説明」、「次の ID」など) が使用されていることに注意してください。 タブ名をクリックすると、その列の図が表示されます。

プロセス ステップ ID: フローチャート内の各図形を識別する番号。 この列は必須であり、Excel テーブルの各値は一意であり、空であってはなりません。 この値はフローチャートに表示されません。

Excel プロセス マップで Visio フローチャートを操作するプロセス ステップ ID

ページの先頭へ

他のステンシルを使用し、データ ビジュアライザーのダイアグラムを作成する

データ ビジュアライザー テンプレートを使用する以外に、データ ビジュアライザー図を作成するときに他のテンプレートのステンシルを使用することもできます。 たとえば、財務取引や在庫管理のプロセス図を作成します。 BPMN 基本テンプレートやワーク フロー オブジェクト テンプレートなど、その他のプロセス用ステンシルもあります。 [個人用図形] ステンシルを使用して、基本図形を追加することもできます。 詳細については、「ユーザー設定のステンシルを作成、保存、共有する」を参照してください。

  1. 既に作成したデータ ビジュアライザーのダイアグラム (基本フローチャートまたは部門連係フローチャート) を開きます。
  2. [作成] を選択して [データからの図の作成] ウィザードを開き、最初のページに値を入力したら、ウィザードに [図形マッピング] ページが表示されるまで、[次へ] を選択します。
  3. [その他の図形] オプションを使用して、1 つまたは複数のステンシルを追加します。
    d867ecf4-7765-4d1c-a9f5-125217af8f0e
  4. 任意の図形を選択し、[図形の種類] 列のデータ値にドラッグしてマップします。
    407ecd58-70f5-477b-b1cc-d9308fee527c

ページの先頭へ

現時点では、データ ビジュアライザー機能では、単一の Excel テーブルからのサブプロセスの作成はサポートされていません。 ただし、1 つの Visio ファイルで異なるテーブルを使用して複数の図を作成し、代替ソリューションとして図形をリンクすることはできます。

  1. Visio デスクトップ アプリで、データ ビジュアライザー テンプレートを選択し、 Excel データ テンプレート のリンクを選択して Excel を開きます。 次に、[ 作成] を選択して Visio データ ビジュアライザー テンプレートを開きます。
  2. Excel データ テンプレートを使用して、プロセスとサブプロセスのテーブルを作成します。 各サブプロセスのテーブルを別のシートに配置し、Excel ファイルを保存します。
    たとえば、Sheet 1: Main Process、Sheet 2: SubProcess1、Sheet 3: SubProcess2 などです。
  3. Visio デスクトップ アプリに戻り、ウィザードを使用して主プロセス テーブルを Visio キャンバスの 1 ページ目にインポートします。
  4. キャンバスの下にある + アイコンを選択してページ 2 を作成します。 [データ] タブで、[ 作成 ] を選択して、インポート ウィザードを再度起動します。 Excel ブックの次のシートからデータをインポートすることを選択し、ウィザードの手順を完了します。
  5. 引き続き Visio で新しいページを作成し、作成したサブプロセス データ テーブルごとにウィザードを使用します。
  6. 最後に、メイン プロセス図を含むページを選択し、図形を右クリックしてサブプロセスにリンクします。 [ハイパーリンク] を選択し、サブプロセス図のいずれかの図形にリンクします。

ページの先頭へ

データ グラフィックをダイアグラムに適用する

ダイアグラムの図形データを視覚化するのに役立つ、データ グラフィックを追加することで、ダイアグラムを充実させることができます。 実際には、ダイアグラムをプロセス ダッシュボードに変換することができ、このダッシュボードでは、データ グラフィックに、主要業績評価指標 (KPI) 情報が図形データに基づくデータ グラフィック アイコンで表示されます。

  1. データ ビジュアライザーのダイアグラムを開きます。
    データ グラフィックを適用するコンテナーを選択します。
  2. [データ>データ グラフィックス フィールド] を選択します。
  3. ダイアグラムに追加するデータ グラフィック フィールドを選択します。
    Visio データ ビジュアライザー ダイアグラムのデータ グラフィックを適用する
    データ グラフィックは、ダイアグラム全体に適用されます。 特定の図形のデータ グラフィックを非表示にするには、それらの行に対して Excel ブックのデータ列を空白のままにします。
  4. 必要な場合は、[データ] タブで追加のオプションを設定できます。詳細については、「データ グラフィックの概要」を参照してください。

ページの先頭へ

図にリンクされた Excel ブックを管理する

必要に応じて、関連付けられている Excel ブックを再リンクまたは更新する必要があります。 Visio から簡単に行うことができます。

データ ビジュアライザー図面にリンクされている Excel ブックの名前が変更されたり、別の場所に移動されたりした場合、Visio 図面と Excel ブック間のリンクは解除されます。 この問題は、Excel テーブルの名前を変更する場合にも発生する可能性があります。

  1. データ ビジュアライザー図面のコンテナーを選択します。 これにより、リボンの [データ ツールのデザイン ] タブが有効になります。
  2. [データ ツール] の [デザイン>ソース データの再リンク] を選択します。
  3. 名前を変更または移動した Excel ブックを参照します。
  4. ブック内の表またはユーザー設定範囲を選択します。
  5. 解除されたリンクを修正するには、[ 再リンク] を選択します。

図面を更新する、またはソース データを更新しようとしたときにリンクが解除されると、Visio から再リンクするように求められます。

重要

図にリンクされている Excel テーブルの列名は変更しないでください。 それ以外の場合、再リンク操作は失敗します。

図にリンクされている Excel ブックを開く

Excel のリンクされたコンテンツは、Visio から直接変更できます。 たとえば、大量のコンテンツを追加して、スプレッドシートのデータを編集した方が簡単な場合があります。

  1. Visio で、データ ビジュアライザー図面のコンテナーを選択します。 これにより、リボンの [データ ツールのデザイン ] タブが有効になります。
  2. [データ ツール] の [デザイン>オープン ソース データ] を選択します。
  3. Excel で変更を行い、ブックを保存して閉じます。
  4. 図の変更を表示するには、[データ ツール] の [デザイン] > [図の更新] の順に選択します。

ページの先頭へ

次の手順

ここでは、データ ビジュアライザー ダイアグラムを作成した後で実行するタスクを示します。

  • テーマ: Visio のテーマは、1 回のクリックで図面に適用できる一連の色と効果です。 テーマを使用することで、図面を本格的な外観にすばやく変更できます。 詳細については、「テーマを使用して図面を本格的な外観にする」を参照してください。
  • レイアウト: Visio には手動ガイドと自動ツールがあり、図面内の図形の位置と間隔を適切に配置するのに役立ちます。 これにより、図形を可能な限りクリアなものにして秩序だった外観を与えることができます。 詳細については、「図面で図形を整理して配置する」を参照してください。
  • エクスポート: データ ビジュアライザーの図面および関連する Excel ブックを Visio テンプレート パッケージ (.vtpx) にエクスポートします。 Visio テンプレート パッケージには、他のユーザーが独自のデータ ビジュアライザーの図をすばやく作成するための開始点として使用できるように、図の設定、ステンシル、およびデータが保存されます。 他のユーザーは、コンピューター上にテンプレート パッケージをインストールできます。 詳細については、「 データ ビジュアライザー テンプレート パッケージのエクスポートとインストール」を参照してください。

ページの先頭へ