Sintomas
Suponha que você crie um índice columnstore clusterizado por meio de uma conexão MARS (Vários Conjuntos de Resultados Ativos) no Microsoft SQL Server 2014. Quando você define o valor de maxdop maior que 1, há falha na criação ou recriação do índice columnstore clusterizado. Além disso, você recebe um erro 35377 semelhante ao seguinte:
Observação
Número do erro: 35377
ErrorSeverity: EX_USER
ErrorOwner: <OwnerName>
rrorFormat: Quando o MARS está ativado, o acesso a índices columnstore clusterizados não é permitido.
ErrorCause: acesso inválido a índices columnstore clusterizados em uma conexão MARS.
ErrorCorrectiveAction: a conexão não deve ser habilitada para MARS.
ErrorFirstProduct: SQL14
Observação Esse problema não ocorre quando você define maxdop igual a 1.
Resolução
Os dois problemas foram corrigidos pela primeira vez na atualização cumulativa seguinte do SQL Server.
Atualização cumulativa 1 para SQL Server 2014 /pt-br/help/2931693
Sobre atualizações cumulativas para o SQL Server
Cada nova atualização cumulativa do SQL Server contém todos os hotfixes e todas as correções de segurança incluídas na atualização cumulativa anterior. Confira as atualizações cumulativas mais recentes para o SQL Server:
Status
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".