KB3082513 - CORREÇÃO: a criação do certificado TDE falhará no SQL Server 2014 SP1 se o número de série for maior que 16 bytes

Aplica-se a
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Express - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Sintomas

Você cria um certificado para TDE (Transparent Data Encryption) no Microsoft SQL Server 2014 Service Pack 1 (SP1). No entanto, se você usar um certificado cujo número de série seja maior que 16 bytes, receberá a seguinte mensagem de erro:

Observação

Mensagem 15297, Nível 16, Estado 56, Linha 1

O certificado, a chave assimétrica ou os dados da chave privada são inválidos.

      

Resolução

Esse problema foi corrigido pela primeira vez na seguinte atualização cumulativa para o SQL Server:

Atualização cumulativa 2 para o SQL Server 2014 Service Pack 1
Observação Depois de instalar essa atualização, você poderá criar o certificado mesmo que o número de série seja maior que 16 bytes. Além disso, você não receberá a mensagem de erro mencionada na seção "Sintomas". No entanto, o número de série será truncado para 16 bytes quando for salvo na coluna cert_serial_number na exibição do catálogo sys.certificates. A ação truncar ocorre somente no modo de exibição de catálogo. Isso significa que o certificado ainda preserva o comprimento original do número de série.

Sobre atualizações cumulativas para o SQL Server

Cada nova atualização cumulativa do SQL Server contém todos os hotfixes e todas as correções de segurança incluídas na atualização cumulativa anterior. Confira as atualizações cumulativas mais recentes para o SQL Server:

Versões de compilação do SQL Server 2014
      

Status

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Referências

Saiba mais sobre a terminologia que a Microsoft usa para descrever atualizações de software.