CORREÇÃO: Não é possível criar uma exibição indexada em um índice columnstore clusterizado e o BCP na tabela falha no SQL Server 2014

Aplica-se a
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Sintomas

Suponha que você tenha uma tabela particionada com um índice columnstore clusterizado no Microsoft SQL Server 2014 e que haja alguns dados na tabela. Ao tentar criar uma exibição indexada na tabela, você recebe a seguinte mensagem de erro:

Observação

Erro do processador de consulta interna: o processador de consulta não pôde obter acesso a uma interface necessária.

Se você criar o índice columnstore clusterizado depois de criar a exibição indexada, o problema não ocorrerá. No entanto, quando você tenta executar uma cópia em massa (BCP) na tabela, a asserção falhará se a tabela contiver o tipo de dados char, nchar, varchar, nvarchar ou varbinary.

Resolução

O problema foi corrigido pela primeira vez na atualização cumulativa seguinte do SQL Server.

Atualização cumulativa 3 para SQL Server 2014 /pt-br/help/2984923

Sobre atualizações cumulativas para o SQL Server

Cada nova atualização cumulativa do SQL Server contém todos os hotfixes e todas as correções de segurança incluídas na atualização cumulativa anterior. Confira as atualizações cumulativas mais recentes para o SQL Server:

      

Status

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".