Sintomas
Suponha que você crie uma tabela com otimização de memória no SQL Server 2014. Em seguida, submete uma consulta na tabela e a consulta especifica uma sugestão que não é reconhecida por SQL Server. Por exemplo, submete a seguinte consulta:
SELECT * FROM dbo.ShoppingCart (non_existing_hint) WHERE ShoppingCartId = 1;
Nessa situação, SQL Server pode falhar e você receber a seguinte mensagem de erro:
Observação
Msg 3624, Nível 20, Estado 1, Linha 27
Um marcar de asserção do sistema falhou. Consulte o registo de erros SQL Server para obter detalhes. Normalmente, uma falha de asserção é causada por um bug de software ou corrupção de dados. Para marcar para danos no banco de dados, considere executar DBCC CHECKDB. Se concordou em enviar informações de perda para a Microsoft durante a configuração, será enviada uma minicaptura para a Microsoft. Pode estar disponível uma atualização da Microsoft no Service Pack mais recente ou numa Correção do Suporte Técnico.
Depois de instalar a atualização, SQL Server não falha neste cenário e recebe uma mensagem de erro semelhante a:
Observação
Msg 10794, Nível 16, Estado 86, Linha 26
A opção de tabela 'xxxxx' não é suportada com tabelas com memória otimizada.
Resolução
Informações de atualização cumulativa
O problema foi corrigido na atualização cumulativa seguinte do SQL Server.
Recomendação: Instale a atualização cumulativa mais recente para o SQL Server
Cada nova atualização cumulativa para SQL Server contém todos os hotfixes e todas as correções de segurança que foram incluídas com a atualização cumulativa anterior. Recomendamos que transfira e instale as atualizações cumulativas mais recentes para SQL Server:
Status
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".