KB2998301 - CORRECÇÃO: Erro 8654 quando executa "INSERT INTO ... SELECT" numa tabela com o índice columnstore agrupado no SQL Server 2014

Aplica-se a
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Sintomas

Suponha que você tenha uma tabela que tenha o índice columnstore clusterizado no Microsoft SQL Server 2014. Quando você tenta carregar dados para a tabela usando o botão INSERT INTO ... SELECT, poderá receber a seguinte mensagem de erro:

Observação

Erro: 8645, gravidade: 17, estado: 1, linha: 1
Ocorreu um tempo limite enquanto aguardava que os recursos de memória executassem a consulta na 'predefinição' do agrupamento de recursos (2). Volte a executar a consulta.

Observação Quando há memória insuficiente para inserção em massa, SQL Server tenta fazer uma inserção não em massa com essa correção. Normalmente, requer significativamente menos memória. A consulta continuará a falhar se não houver memória suficiente para fazer a inserção não em massa.

Resolução

Esta correção introduz um novo sinalizador de rastreio 9348 para utilizar estimativas de cardinalidade do otimizador de consultas para decidir se a inserção em massa deve ou não ser iniciada. Se o número estimado de linhas a inserir for inferior a 102400, SQL Server não tentará fazer uma inserção em volume. Se forem estimadas mais de 102400, será iniciada uma inserção em massa.
O problema foi corrigido na atualização cumulativa seguinte do SQL Server.

Atualização cumulativa 4 para SQL Server 2014 /pt-pt/help/2999197

Sobre atualizações cumulativas para o SQL Server

Cada nova atualização cumulativa para SQL Server contém todos os hotfixes e todas as correções de segurança que foram incluídas com a atualização cumulativa anterior. Consulte as atualizações cumulativas mais recentes para SQL Server:

      

Status

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".