دفاتر ملاحظات للصفوف eDiscovery دلائل التصدير

ملاحظة

تم تحقيق الغرض المطلوب من هذه المقالة وستتم إزالتها قريباً. لمنع مشاكل "لم يتم العثور على الصفحة"، نقوم بإزالة الارتباطات التي نعرف ماهيتها. إذا قمت بإنشاء ارتباطات تؤدي إلى هذه الصفحة، يُرجى إزالتها وسنقوم معاً بالحفاظ على اتصال الويب.

مقدمة

دفتر ملاحظات للصفوف ودفتر ملاحظات فريق العمل ودفاتر ملاحظات Skype يمكن توفير تصدير محتوى بطريقتين مختلفتين:

  1. للمدرسين والطلاب: تجربة داخل التطبيق لحفظ نسخة إما إلى حساب Microsoft 365 Enterprise أو Education أو حساب Microsoft للمستهلكين.  يتم توثيق ذلك في دليل تصدير In-App دفتر الملاحظات للصفوف.
  2. للمسؤولين: eDiscovery للتصدير المجمع أو المحدد لمحتوى Microsoft 365.

يصف هذا المستند تصدير eDiscovery لدفاتر ملاحظات الصفوف للتصدير المجمع، مما يمكن الاستعلامات المرنة للمحتوى الخاص بالدور للمعلم أو الطالب.  تفرض "دفاتر ملاحظات للصفوف" إذن المحتوى المستند إلى الدور المطبق على بنية معينة لدفتر ملاحظات.  لذلك، يجب أن تحتفظ البنية والأدوار والأذونات الخاصة بالمحتوى المصدر على بنية طلب تصدير المستخدم، كما هو موضح في هذا المستند.  

ارجع إلى وثائق Microsoft 365 ل eDiscovery لتقديم أساسيات البحثوالتصدير

يقدم القسم الأول من هذا المستند بنية دفتر ملاحظات للصفوف ونموذج الأذونات، متبوعا بخطوات مفصلة للتصدير باستخدام eDiscovery. 

الخلفية

تنسيق تخزين OneNote

  • دفتر الملاحظات (مجلد في SharePoint Online يتوافق مع SPFolder)

    • القسم (الملف في SharePoint Online يتوافق مع SPFile)

    • مجموعة الأقسام (مجلد، في SharePoint Online يتوافق مع SPFolder)

      • القسم (الملف في SharePoint Online يتوافق مع SPFile)

إذا كان دفتر ملاحظات OneNote عبارة عن مجلد، فستكون مجموعات المقاطع مجلدات فرعية ضمن مجلد دفتر الملاحظات. المقاطع عبارة عن ملفات (بملحق one.)  ليس لدى الصفحات تمثيل فعلي في SharePoint، بدلا من ذلك، الصفحات هي محتويات ملفات المقاطع.

ما هو دفتر ملاحظات الصف

دفتر الملاحظات للصفوف عبارة عن قالب يسمح للمعلم بالوصول R/W إلى دفتر الملاحظات بأكمله بينما يتمتع الطلاب بوصول R/W (إلى مجموعة المقاطع الخاصة بهم) ووصول R/O إلى مجموعات المقاطع المشتركة مع المعلم. يمكن أن تحتوي مجموعات الأقسام الموجودة في المستوى الثاني من الشجرة أدناه على مجموعات الأقسام نفسها (تمت إضافتها لاحقا من قبل المعلم).

ما هو دفتر الملاحظات للصفوف

نموذج أذونات دفتر ملاحظات للصفوف

لكل مجلد وملف في SharePoint Online أذونات مقترنة به:

  • موروثة من أصل
    وهذا يسمى توريث الأذونات. هذا يعني أن أذونات الوالدين يتم تمريرها إلى الأطفال.
  • معرف في المجلد/الملف نفسه
    يمكن لملف أو مجلد تقسيم سلسلة التوريث هذه من أصل إلى تابع. في هذه المرحلة، تكون أذونات الطفل مستقلة عن أذونات الوالدين. يسمح SharePoint Online بإضافة الأذونات وتحريرها وإزالتها. ولا يؤثر أي من هذه التغييرات على الوالدين الأصليين.

يحتوي كل من مجموعات مقاطع جذر دفتر ملاحظات للصفوف ومجموعات مقاطع دفتر ملاحظات للصفوف (مكتبة _Content ومساحة _Collaboration و_Teacher فقط، مجموعات مقاطع الطلاب الخاصة) على أذونات معرفة لنفسها. هذا يعني أن أذوناتهم مقطوعة عن سلسلة الميراث ولديهم أذونات خاصة بهم.

لمحات "دفاتر ملاحظات للصفوف" أذونات موروثة من "مجموعات المقاطع".

بعد الاطلاع على شكل دفتر الملاحظات للصفوف، يتم منح الأذونات التالية للمستخدمين:

  • يمنح "مجلد دفتر الملاحظات" المعلمين أذونات للقراءة/الكتابة والطلاب للقراءة فقط
  • تمنح "مكتبة _Content" أذونات للمعلمين للقراءة/الكتابة والطلاب للقراءة فقط يمنح المجلد "مساحة _Collaboration" المعلم أذونات للقراءة والكتابة. يتمتع الطلاب أيضا بأذونات القراءة والكتابة.
  • تمنح كل مجموعة قسم خاصة للطلاب المعلمين وطالب مجموعة الأقسام فقط حق الوصول للقراءة/الكتابة.

الأذونات المقابلة في SharePoint Online استنادا إلى الدور

الدور اسم إذن SharePoint للقراءة/الكتابة
المعلم/القائد تحكم كامل
الطالب / العضو مساهمة

تجسيدات دفتر الملاحظات للصفوف

تتضمن التجسيدات الحالية لدفتر الملاحظات للصفوف ما يلي:

  • دفتر ملاحظات للصفوف (للمدرسين)
  • دفتر ملاحظات سكايب (مستخدم بواسطة Skype edu)
  • دفتر ملاحظات فريق العمل (لمسؤولي المدرسة)

 
يتبع كل من دفاتر ملاحظات الصفوف وSkype البنية المذكورة أعلاه. أما دفتر الملاحظات الخاص بفريق العمل، فله بنية مماثلة مع تسميات مختلفة. يتم تسمية المعلمين بقادة ، ويتم تسمية الطلاب بالأعضاء.

ولذلك، سيبدو الهيكل على الشكل التالي: دفتر ملاحظات فريق العمل

يتم تخزين دفاتر الملاحظات للصفوف في مواقع SharePoint Online:

يتم تخزين دفاتر ملاحظات للصفوف في مواقع SharePoint، عبر القوائم الافتراضية ضمن مجلدات مثل "دفاتر ملاحظات الصفوف" و"دفاتر ملاحظات فريق العمل" و"دفاتر ملاحظات Skype". تتم ترجمة أسماء المجلدات هذه استنادا إلى لغة دفتر الملاحظات للصفوف.

أما بالنسبة لدفتر ملاحظات للصفوف في Teams، فيوجد دفتر ملاحظات صف واحد لكل فريق. علاوة على ذلك، تم توفيره ليكون دفتر ملاحظات افتراضيا مخزنا في مكتبة الأصول.

بالنسبة إلى تطبيق متجر SharePoint القديم ل "منشئ دفاتر ملاحظات للصفوف في OneNote"، يتم تخزين دفاتر الملاحظات في القائمة التي تحمل العنوان "EduOneNoteAppDocuments". سيكون لدى كل مدرس مجلد فرعي بعنوان "<البريد الإلكتروني>_Courses" حيث يتم تخزين دفتر ملاحظاته.

مثال:

EduOneNoteAppDocuments

                         <JohnDoe>@contoso.org_Courses 

خطوات مدخل مسؤول دليل eDiscovery

  1. قم بتسجيل الدخول إلى مدخل المسؤول بشكل خاص باستخدام مستعرض Edge.

  2. حدد مسؤول.
    زر مسؤول

  3. حدد مراكز مسؤول.
    مراكز الإدارة

  4. قم بتوسيع القائمة المنسدلة من مراكز مسؤول، ثم حدد الأمان والتوافق.
    تحديد الأمان والتوافق

  5. ضمن القائمة المنسدلة، حدد بحث & التحقيق ثم حدد eDiscovery.
    حدد ediscovery

  6.   حدد إنشاء حالة لإدخال اسم الحالة ووصفها.
    ملاحظة:
    حدد إنشاء حالة

    • يجب أن يتم إنشاء كل استعلام بيانات ضمن حالة eDiscovery.
    • يتم استخدام هذه التسمية لأن وظيفة المسؤول هذه تستخدم عادة في سياق حالة قانونية أو حالة تنظيمية. 
  7. يتم حفظ الحالة التي تم إنشاؤها حديثا أدناه.
    إنشاء حالة مكتملة

  8. حدد «فتح»، ثم حدد «تصدير»، ثم حدد + لإنشاء استعلام بحث جديد.
    حدد علامة الجمع

  9. أدخل اسما للاستعلام، ثم حدد الطلب "البحث في أي مكان ". 

  10. حدد "خانة اختيار SharePoint" ثم حدد "التالي". 
    مشاركة النقاط

  11. حدد اسم دفتر الملاحظات للصفوف أو بدلا من ذلك اسم الطالب للحصول على مجلده/مجلدها.  يستخدم التدرج الهرمي لدفتر ملاحظات للصفوف مجلدات مكتبة مستندات SharePoint، حيث يكون اسم الصف هو مجلد المستوى الأعلى، وبالتالي يؤدي تحديد ذلك إلى الحصول على جميع المجلدات الفرعية - مجلد فرعي واحد لكل قسم من الطلاب.  لذا فإن تحديد اسم الطالب في هذا الاستعلام سيؤدي فقط إلى إرجاع نتيجة هذا المجلد الفرعي لقسم ذلك الطالب.   في هذه الحالة ، نحن نبحث عن دفتر الملاحظات بأكمله ، "اختبار الفئة 1 6-20".  اضغط على التالي..
    كلمة البحث الأساسية

  12. سيتم حفظ الاستعلام (تمييزه) وتظهر النتائج في الجزء الأيسر.  لاحظ أن هناك 9 عناصر مدرجة. حدد "معاينة نتائج البحث"
    معاينة نتائج البحث

  13. ستعرض نتائج البحث قائمة بالعناصر التسعة.  سيؤدي النقر فوق أي من العناصر في القائمة في الجزء الأيمن إلى عرض المعلومات الخاصة بهذا العنصر.   بالنسبة لدفتر الملاحظات المحدد أدناه، هذا هو مسار المجلد على SharePoint للمجلد الجذر لدفتر الملاحظات للصفوف.   انسخ مسار المجلد هذا إلى الحافظة حيث سنستخدمه في الاستعلام الثاني عن المحتويات داخل هذا المجلد.  ملاحظة: لا يمكنك تنزيل هذا العنصر لأنه مجرد مجلد.   أغلق هذه النافذة.
    معاينة نتائج البحث 2

  14. سيؤدي إغلاق النافذة إلى العودة إلى صفحة البحث السابقة.  انقر فوق القلم لتحرير الاستعلام
    تحرير البحث

  15. أضف شرطا جديدا إلى الاستعلام بالنقر فوق الزر:
    إضافة شرط

  16. انقر فوق "إظهار قائمة الكلمات الأساسية" لتحسين الاستعلام لتضمين مسار المجلد الجذر لدفتر الملاحظات للصفوف في الخطوة السابقة.  سيؤدي ذلك إلى عرض قائمة منسدلة بالكلمات الأساسية.   ستحتاج إلى استبدال الاستعلام "Test Class 1 6-20" بمسار المجلد الخاص بدفتر الملاحظات للصفوف، باستخدام الكلمة الأساسية، المسار:"<المسار إلى مجلد دفتر ملاحظات الصفوف/".   لاحظ أن المسار يجب أن يكون بعلامات اقتباس كما هو موضح أدناه ويجب أن ينتهي بشرطة مائلة.  بدون شرطة مائلة في المسار، سيفشل الاستعلام.
    التحقق من الاستعلام عن أخطاء كتابية

  17. حدد "إضافة شرط" من الأعلى لتحسين البحث إلى أنواع ملفات One Note (.one) فقط.  سترى قائمة منسدلة بأنواع الشروط.  حدد "نوع الملف" المميز أدناه،
    القوائم المنسدلة

  18. حدد نوع الملف "one"، لأنه الملحق لملفات OneNote.  ثم انقر فوق "بحث".
    نوع الملف

  19. سيرجع هذا الاستعلام نتائج كل ملفات one. الموجودة في المجلد، في هذه الحالة 14 عنصرا.  انقر فوق "معاينة نتائج البحث" للاطلاع على قائمة ملفات one. في المجلد:
    معاينة نتائج البحث

  20. لاحظ أن قائمة النتائج تتضمن كافة ملفات one. في التسلسل الهرمي بأكمله أسفل مسار المجلد الجذر لدفتر ملاحظات للصفوف.  سيتضمن ذلك مجلدا لكل طالب.     إذا كنت تريد تحديد ملف ONE. واحد ، فيمكن القيام بذلك باستخدام "الرجاء النقر هنا".  يمكنك تحديد ملف واحد فقط في كل مرة باستخدام هذا إذا أردت ذلك، ولكن لن ينعكس التسلسل الهيكلي لدفتر الملاحظات في حال تنزيل ملفات one. مفردة.   لاحظ أيضا أنه لا يمكن فتح الملف one. في OneNote لأنه ليس ملف OneNote كاملا صالحا لأنه يتطلب . جدول المحتويات ضمن التسلسل الهيكلي ليكون ملفا صالحا (سيوفر فريق OneNote عملية استيراد لإعادة ترطيب دفتر الملاحظات منه). تسلسل هيكلي واحد).
    غير معتمدة في المعاينة

  21. أغلق مربع الحوار للعودة إلى صفحة الاستعلام.   ستحتاج إلى النقر فوق السهم لأسفل المميز (سيظهر التمرير كلمة "تصدير") لبدء تصدير التسلسل الهيكلي للمجلدات بالكامل لدفتر الملاحظات بأكمله.  سيؤدي النقر فوق السهم لأسفل إلى ظهور رسالة "تصدير النتائج".  حدد هذا الخيار.
    تصدير

  22. سيتم الآن عرض صفحة تطلب خيارات التصدير.  حدد الزر التبادلي الأول، "كل العناصر باستثناء تلك التي لها تنسيق غير متعرف عليه..." وانقر فوق "بدء التصدير"
     

  23. بمجرد اكتمال التصدير، يتم عرض النتائج في الجزء الموجود على اليسار.  حدد الآن "تنزيل النتائج المصدرة"
    تنزيل النتائج المصدرة

  24. ستعرض صفحة تأكيد تنزيل النتائج، وتعرض مفتاح التصدير الذي يجب نسخه إلى الحافظة لاستخدامه في تطبيق تصدير eDiscovery في الخطوة التالية.  بعد النسخ إلى الحافظة، حدد "تنزيل النتائج"
    تنزيل النتائج

  25. عند النقر فوق "تنزيل النتائج"، ستتم مطالبتك بتثبيت أداة تصدير eDiscovery، إذا لم تكن قد قمت بتشغيل تصدير مسبقا.  حدد تثبيت.
    تثبيت

  26. ثم انقر فوق "فتح" في مطالبة التحقق من صحة الأمان أدناه لبدء التنزيل
    فتح

  27. بعد فتح أداة التصدير، ستتم مطالبتك بلصق المفتاح من أعلى، والتحديد لتنزيل الملفات:
    مفتاح التصدير

  28. ستقوم أداة التصدير بإعداد تقرير عن التقدم الذي تم إجراؤه أثناء العملية، والذي قد يستغرق بعض الوقت استنادا إلى عدد الملفات المطلوب تنزيلها.
    إغلاق

  29. ويتم تضمين نتائج عملية التصدير في المجلد المحدد، الذي يحتوي على عدة مجلدات فرعية. يحتوي المجلد الفرعي الأول على ملخص للتصدير، ويحتوي المجلد "SharePoint" على محتويات ملف OneNote في مجلد العقدة الطرفية:
    موقع ملف دفتر ملاحظات الصف الذي تم تصديره

  30. سيحتوي الانتقال إلى مجلد "أصول الموقع" على المجلد الجذر لدفتر ملاحظات الصف، مع عرض مجلد لكل مجموعة من مجموعات المقاطع في دفتر الملاحظات، وصفحة الترحيب ضمن مقطع دفتر الملاحظات الأول.  يوجد أسفل "مساحة التعاون ومكتبة المحتويات" المحتوى المشترك لدفتر الملاحظات، كما يوجد مجلد لكل من الطلاب (الطالب 48 فيكتور والطالب 50 X-ray هما الطالبان)
    أصول موقع ntoebook من الفئة المصدرة

  31. سيؤدي الانتقال إلى المجلد (مجموعة المقاطع) ل "Student 48 Victor" إلى إظهار المقاطع (ملفات one.) الموجودة ضمن مجموعة مقاطع الطالب.
    أصول موقع ntoebook من الفئة المصدرة 2

لإعادة إنشاء دفتر الملاحظات، يمكن للطلاب تنفيذ الخطوات التالية:

  1. افتح OneNote 2016 وأنشئ دفتر ملاحظات جديدا (يفضل على OneDrive)

  2. افتح كل مقطع .one في OneNote 2016 عن طريق إما:

    • النقر المزدوج فوق الملف one.
    • في عام 2016 ، عند الانتقال إلى File > Open > Browse > View All Files (*.*) > حدد . ملف > واحد انقر فوق "فتح"
  3. انسخ المقاطع إلى دفتر الملاحظات الجديد عن طريق:

    • النقر فوق المقطع وسحبه إلى دفتر الملاحظات الجديد
    • انقر بزر الماوس الأيمن فوق علامة تبويب المقطع وحدد نقل أو نسخ، وحدد دفتر الملاحظات الجديد، ثم انقر فوق "نسخ"

أين القصة التجارية ل OneNote حول كيفية فتح مستخدم ؟ ملف واحد.

ملاحظة: تتيح أذونات OneNote API للمستخدمين تعيين أذونات محددة لبنية مستند OneNote. لذلك فهو مثل دفتر ملاحظات الصفوف.