INLEIDING
In dit artikel wordt cumulatief updatepakket 1 voor Microsoft SQL Server 2012 beschreven. Deze update bevat hotfixes voor problemen die zijn opgelost na de release van SQL Server 2012 Service Pack 1 (SP1).
Opmerking Dit buildnummer van dit cumulatieve updatepakket is 11.0.3321.0.
Het is raadzaam hotfixes te testen voordat u ze in een productieomgeving implementeert. Omdat de builds cumulatief zijn, bevat elke nieuwe fixrelease alle hotfixes en alle beveiligingspatches die aanwezig waren bij de vorige herstelrelease van SQL Server 2012 SP1. Het is raadzaam om de meest recente fixversie toe te passen die deze hotfix bevat.
Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:
2772858 De SQL Server 2012-builds die zijn uitgebracht nadat SQL Server 2012 Service Pack 1 is uitgebracht
Belangrijke opmerkingen over het cumulatieve updatepakket
- De hotfixes voor SQL Server 2012 SP1 zijn nu beschikbaar in meerdere talen. Daarom is er slechts één cumulatief hotfixpakket voor alle talen.
- Eén cumulatief hotfixpakket omvat alle onderdeelpakketten. Met het cumulatieve updatepakket worden alleen de onderdelen bijgewerkt die op het systeem zijn geïnstalleerd.
Meer informatie
Cumulatieve update 1 voor SQL Server 2012 SP1 verkrijgen
Een ondersteund cumulatief updatepakket is nu beschikbaar bij Microsoft. Het is echter alleen bedoeld om de problemen op te lossen die in dit artikel worden beschreven. Pas het alleen toe op systemen die deze specifieke problemen ondervinden. Dit cumulatieve updatepakket kan aanvullende tests ontvangen. Als u niet ernstig last hebt van een van deze problemen, raden we u daarom aan te wachten op het volgende servicepack voor SQL Server 2012 dat de hotfixes in dit cumulatieve updatepakket bevat.
Als de cumulatieve update kan worden gedownload, vindt u de sectie 'Hotfix-download beschikbaar' bovenaan dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, neem dan contact op met de klantenservice en ondersteuning van Microsoft om het cumulatieve updatepakket te verkrijgen.
Opmerking: als er nog meer problemen optreden of als er problemen nodig zijn, moet u mogelijk een afzonderlijke serviceaanvraag maken. De gebruikelijke ondersteuningskosten zijn van toepassing op aanvullende ondersteuningsvragen en problemen die niet in aanmerking komen voor dit specifieke cumulatieve updatepakket. Voor een volledige lijst met telefoonnummers van de klantenservice en ondersteuning van Microsoft of om een afzonderlijke serviceaanvraag te maken, gaat u naar de volgende Microsoft-website:
Hotfixes die deel uitmaken van dit cumulatieve updatepakket
Microsoft Knowledge Base-artikelen waarin deze hotfixes worden besproken, worden gepubliceerd zodra ze beschikbaar zijn.
Voor meer informatie over de SQL Server-bugs klikt u op de volgende artikelnummers in de Microsoft Knowledge Base:
| VSTS-bugnummer | KB-artikelnummer | Beschrijving |
|---|---|---|
| 1086784 | 2406666 | FIX: de fout '[Teradata-database] [3737]' wanneer u op 'Aantal' klikt in de wizard Ontwerp aggregatie in SSAS 2008, SSAS 2012 of SSAS 2008 R2 |
| 1078523 | 2445812 | OPLOSSING: een kolom die gebruikmaakt van het gegevenstype DATETIME kan niet worden gerepliceerd naar een Oracle-abonnee door middel van transactionele replicatie in SQL Server 2008, in SQL Server 2008 R2 of in SQL Server 2012 |
| 1078647 | 2644794 | FIX: fFalse-beweringsfout wanneer u de waarde probeert te converteren van een XML-kolom naar een XML-variabele in SQL Server 2008, in SQL Server 2008 R2 of in SQL Server 2012 |
| 1078655 | 2645648 | FIX: De exportprocedure mislukt wanneer u een 64-bits SSRS 2008 R2-rapport, SSRS 2012-rapport of een SSRS 2008-rapport met meerdere niveaus van een documenttoewijzing exporteert naar de PDF-indeling |
| 1078512 | 2651629 | FIX: Foutbericht wanneer u DTA gebruikt om een of meer query's af te stemmen op een database met veel objecten in SQL Server 2008, in SQL Server 2008 R2 of in SQL Server 2012 |
| 1086762 | 2661644 | FIX: Access violation in the sqlservr! ReplicaToPrimaryPageCopier::ReadIoCompletionRoutine function in SQL Server 2008 R2 of in SQL Server 2012 |
| 1078579 | 2667037 | FIX: Fout 'De indeling van de verbindingsreeks is niet geldig' wanneer u probeert een onderhoudsplan te maken voor een SQL Server 2008 R2- of SQL Server 2012-server |
| 1078631 | 2667742 | FIX: fout 'onvoldoende geheugen' wanneer u ODBC gebruikt met SQL Server 2012, SQL Server 2008 R2 of SQL Server 2008 |
| 1078541 | 2671078 | FIX: Foutbericht 'Er wordt geprobeerd de waarde van een niet-NULL-waardige kolom in te stellen op NULL' wanneer u een MERATE-instructie gebruikt in SQL Server 2008, in SQL Server 2008 R2 of in SQL Server 2012 |
| 1086761 | 2671318 | FIX: De eerste uitvoering van de xp_cmdshell opgeslagen procedure wordt pas voltooid als de laatste uitvoering in SQL Server 2012 is voltooid |
| 1078538 | 2680799 | FIX: Foutbericht wanneer u een volledige populatie van een index met volledige tekst uitvoert met behulp van woordbrekers voor Chinees in SQL Server 2008, in SQL Server 2008 R2 of in SQL Server 2012 |
| 1078582 | 2697983 | FIX: Er is een onjuiste waarde opgeslagen in de TIME_ZONE kolom van de tabel BACKUPSET in SQL Server 2008 R2 of in SQL Server 2012 |
| 1078535 | 2698639 | FIX: de prestaties van een SELECT-instructie die een LIKE-operator en een ESCAPE-component bevat, zijn laag in SQL Server 2008 R2 of in SQL Server 2012 |
| 1078588 | 2699013 | FIX: SQL Server 2012, SQL Server 2008 R2 of SQL Server 2008 reageert niet meer en de fout 'Niet-renderende planner' wordt geregistreerd |
| 1078516 | 2703193 | FIX: Onjuiste resultaten wanneer u een parallelle query uitvoert met een columnstore-index in SQL Server 2012 |
| 1078593 | 2706601 | FIX: reeksgroepen in een rapport ontbreken wanneer u het rapport weergeeft in SQL Server 2008 Reporting Services of in nieuwere versies van Reporting Services |
| 1078597 | 2708027 | FIX: Foutbericht 'Er is een fout opgetreden tijdens het verwerken van het rapport' wanneer u een voorbeeld van een SSRS 2008 R2- of SSRS 2012-rapport probeert weer te geven nadat u de gegevenssetsortering hebt ingesteld op Grieks of Greek_100 |
| 1078527 | 2708786 | FIX: toegangsfout bij het bouwen van een columnstore-index voor een tabel in SQL Server 2012 |
| 1078530 | 2709075 | Fout 'Er is een ernstige fout opgetreden bij de huidige opdracht' wanneer u een full-text query uitvoert met het predicaat CONTAINS in SQL Server 2012 |
| 1078649 | 2713151 | FIX: Toegangsfout wanneer u Database Engine Tuning Advisor gebruikt om een tabel af te stemmen in SQL Server 2008, in SQL Server 2008 R2 of in SQL Server 2012 als u het selectievakje Inclusief gefilterde indexen inschakelt |
| 1078547 | 2713827 | FIX: Fout 'Dataflow -' wanneer u een SSIS-pakket probeert te openen in SSIS 2012 |
| 1078603, 1086774 | 2714634 | OPLOSSING: In SQL Server 2008 R2 of SQL Server 2012 zijn veel scripts gegenereerd voor een gepartitioneerde tabel die gebruikmaakt van de functie voor gegevenscompressie |
| 1078544 | 2714937 | FIX: Foutbericht 'Er bestaat geen object met een herkomst-id' wanneer u een SSIS 2012-pakket uitvoert |
| 1078573 | 2720171 | FIX: Foutbericht bij het uitvoeren van een SSIS-pakket als de sys.xp_regread opgeslagen procedure wordt ingetrokken in SQL Server 2012: 'De EXECUTE-machtiging is geweigerd voor het object 'xp_regread'" |
| 1086770 | 2723979 | FIX: Toegangsfout in SQL Server interne deadlock monitor wanneer u meerdere toepassingen samen uitvoert met Meerdere actieve resultaatsets ingeschakeld in SQL Server 2008 R2 of in SQL Server 2012 |
| 1078613, 1078616 | 2725950 | FIX: Trage of impasse wanneer u een database herstelt en tegelijkertijd instructies uitvoert in SQL Server 2012 |
| 1078658 | 2727322 | FIX: Onjuiste resultaten worden geretourneerd wanneer u een query uitvoert die parallellisme gebruikt in het query-uitvoeringsplan in SQL Server 2008, in SQL Server 2008 R2 of in SQL Server 2012 |
| 1086769 | 2728419 | FIX: Foutbericht 'Afstemmingsproces onverwacht afgesloten' wanneer u Database Engine Tuning Advisor uitvoert met de rol db_owner in SQL Server 2008 R2 of in SQL Server 2012 |
| 1086771 | 2728534 | FIX: Fout 'Een systeembevestigingscontrole is mislukt' wanneer u een niet-geclusterde index opnieuw maakt voor een kolom in SQL Server 2008 R2 of in SQL Server 2012 |
| 1086773 | 2731068 | FIX: 'Er is een onverwachte fout opgetreden' wanneer u een query uitvoert op bepaalde berekeningsgegevens van een SSAS-tabellair model met behulp van SQL Server 2008 R2, PowerPivot voor Excel 2010 of SQL Server 2008 R2, PowerPivot voor SharePoint 2010 |
| 1086772 | 2737499 | FIX: De eigenschap KeepTogether werkt niet wanneer u een rapport genereert dat een tablix bevat in SSRS 2008 R2 of in SSRS 2012 |
| 1078575 | 2737580 | FIX: interne fout bij het uitvoeren van query's op een niet-rechthoekig mining-model met behulp van DMX of MDX in SQL Server 2012 Analysis Services |
| 1086766 | 2738197 | FIX: Werkthreads worden niet onmiddellijk geactiveerd wanneer meerdere I/O-intensieve taken tegelijkertijd worden uitgevoerd in SQL Server 2012 |
| 1086767 | 2739940 | FIX: de database is offline en bevindt zich in de herstelstatus wanneer u een index opnieuw opbouwt in SQL Server 2012 als het transactielogboek vol is |
| 1086780 | 2752511 | FIX: Bericht 'Rekenkundige overloopfout' wanneer u de procedure 'Opgeslagen sys.sp_tables_info_90_rowset_64 systeem uitvoert op een gekoppelde server in SQL Server 2012 |
| 1086781 | 2754444 | FIX: Foutbericht 'Index en lengte moeten verwijzen naar een locatie in de tekenreeks' wanneer u een grote hoeveelheid gegevens ophaalt uit SAP BW in een SSIS 2012-pakket |
| 1086782 | 2754939 | FIX: Toegangsfout treedt op wanneer u een full-text query uitvoert in SQL Server 2012 |
| 1086785 | 2755079 | FIX: Wijzigingen worden niet gesynchroniseerd naar abonnees nadat u een artikelfilter hebt gewijzigd in een transactionele replicatiepublicatie in SQL Server 2008, in SQL Server 2012 of in SQL Server 2008 R2 |
| 1086763 | 2756097 | FIX: 'Community Technology Preview (August CTP)' wordt weergegeven in de installatie- of verwijderwizard van een update van SQL Server 2012 |
| 1086765 | 2762557 | FIX: Foutbericht 'Proces lijkt niet rendabel te zijn op Scheduler' wanneer u een query uitvoert in SQL Server 2012 |
| 1086783 | 2762559 | FIX: Fouten in SQL Server 2012 worden weergegeven in het dialoogvenster Meldingen van taakstatus in System Center Operations Manager 2012 |
| 1086786 | 2762593 | FIX: Tablediff utility rapporteert onjuiste resultaten wanneer een tabel een primaire sleutel bevat in een uniqueidentifier-kolom in SQL Server 2012 |
| 1115973 | 2780716 | FIX: Gegevensverlies wanneer u Microsoft Azure SQL Database exporteert naar een .bacpac-pakket voor toepassingen in een gegevenslaag |
| 1116032 | 2780719 | FIX: Gegevensverlies wanneer u een toepassing in een gegevenslaag importeert vanuit een .bacpac-pakketbestand in Microsoft Azure SQL Database |
Cumulatieve updatepakketinformatie
Informatie over opnieuw opstarten
Nadat u deze cumulatieve update hebt toegepast, moet u de computer wellicht opnieuw opstarten.
Registergegevens
Als u een van de hotfixes in dit pakket wilt gebruiken, hoeft u geen wijzigingen in het register aan te brengen.
Dit cumulatieve updatepakket verwijderen
Ga als volgt te werk om dit cumulatieve updatepakket te verwijderen:
Open in het Configuratiescherm het onderdeel Software
-item.Opmerking Als u Windows 7 gebruikt, opent u het item Programma's en onderdelen in Configuratiescherm.
Zoek de vermelding die is geïnstalleerd door dit cumulatieve updatepakket.
Klik met de rechtermuisknop op de vermelding en selecteer vervolgens Verwijderen om het cumulatieve updatepakket te verwijderen.
Meer informatie
Voor meer informatie over het Incremental Servicing Model voor SQL Server klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:
935897
Er is een incrementeel onderhoudsmodel beschikbaar van het SQL Server-team om hotfixes te leveren voor gemelde problemen
Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over het naamgevingsschema voor SQL Server-updates:
822499
Naamgevingsschema voor software-updatepakketten voor Microsoft SQL Server
Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over de terminologie van software-updates:
824684
Beschrijving van de standaardterminologie die wordt gebruikt voor Microsoft-software-updates