KB3091643 - FIX: Er treedt een fout op wanneer u SQL Server replicatie configureert of een gekoppelde server instelt in SQL Server 2012 of SQL Server 2014

Van toepassing op
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptomen

Wanneer het maken van de servicehoofdsleutel voor Microsoft SQL Server 2012 of SQL Server 2014 tijdens de installatie mislukt, wordt deze fout niet correct geregistreerd door SQL Server. Dit leidt tot bepaalde problemen. Wanneer u bijvoorbeeld SQL Server replicatie probeert te configureren, wordt het volgende foutbericht weergegeven:

Opmerking

Er is een fout opgetreden tijdens het ontsleutelen. Er is geen externe gebruiker 'distributor_admin' toegewezen aan lokale gebruiker '(null)' van de externe server 'repl_distributor'. De databasecontext is gewijzigd in 'master'. (Microsoft SQL Server, fout: 15466)

Wanneer u een gekoppelde server probeert te maken samen met externe aanmeldingen, treedt de volgende fout op:

Opmerking

Er is een fout opgetreden tijdens het ontsleutelen

Daarnaast wordt mogelijk het volgende foutbericht weergegeven in het foutenlogboek van SQL Server:

Opmerking

< Datum><Tijd> SPID5S Service Master Key kan niet worden ontsleuteld met een van deze versleutelingen. Zie sys.key_encryptions voor details.

Wanneer u een query uitvoert op de catalogusweergave sys.symmetric_keys, wordt één rij voor de servicehoofdsleutel geretourneerd. Wanneer u een query uitvoert op de catalogusweergave sys.key_encryptions, wordt er geen rij geretourneerd. Het verwachte resultaat is twee rijen.

Oplossing

Nadat u deze update hebt toegepast, blijven de metagegevens schoon als tijdens de installatie een fout optreedt bij het maken van de servicehoofdsleutel en wordt bij het opnieuw starten van de SQL Server-service opnieuw geprobeerd een servicehoofdsleutel te maken. Bovendien worden er meer foutberichten over het fout bij het maken van de servicehoofdsleutel in het foutenlogboek vastgelegd.

Opmerking

  • Als u dit probleem bent tegengekomen, werkt deze update niet en moet u een van de tijdelijke oplossingen gebruiken die worden vermeld in de sectie 'Tijdelijke oplossing'.
  • Als u de wijzigingen in deze cumulatieve update wilt gebruiken, moet u SQL Server installeren met behulp van de functie Productupdate en een slipstream-installatie uitvoeren met RTM + SP + CU.

Het probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server:

Aanbeveling: Installeer de meest recente cumulatieve update voor SQL Server

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. We raden u aan de meest recente cumulatieve updates voor SQL Server te downloaden en te installeren:

      

Tijdelijke oplossing

Als dit probleem zich al voordoet, kunt u een van de volgende handelingen uitvoeren:

  • Genereer de servicehoofdsleutel opnieuw met behulp van de volgende Transact-SQL-instructie:

    ALTER SERVICE MASTER KEY FORCE REGENERATE
    
  • Installeer het exemplaar van SQL Server opnieuw.

Als u dit probleem ondervindt tijdens de installatie van SQL Server, kunt u deze stappen volgen voordat u SQL Server installeert:

  • Start het besturingssysteem opnieuw.
  • Meld u aan bij de RDP-sessie met het serviceaccount van SQL Server.
  • Wacht enkele minuten en meld u vervolgens af nadat het gebruikersprofiel volledig is gemaakt.
  • Start na een paar minuten het instellen van SQL Server.

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.