Symptomen
Neem als voorbeeld het volgende scenario:
- U gebruikt replicatie in Microsoft SQL Server 2012 of SQL Server 2014.
- U voegt een abonnement toe aan het Replicatie-abonnement en verwijdert het.
In dit scenario wordt mogelijk het volgende foutbericht 515 weergegeven:
Opmerking
De waarde NULL kan niet worden ingevoerd in kolom 'article_id', tabel '<DistributionDatabaseName.dbo>'. MSrepl_commands'; Kolom staat geen null-waarden toe. INSERT fails.
Oorzaak
Dit probleem treedt op vanwege een regressie in SQL Server 2012. Wanneer u een abonnement toevoegt en het vervolgens verwijdert, worden replicatiemetagegevens over het abonnement onmiddellijk verwijderd, omdat er een vertraging optreedt voordat de LogReader de opdracht tegenkomt om het abonnement toe te voegen.
Oplossing
Het probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server.
Cumulatieve update 1 voor SQL Server 2012 SP2 /nl-nl/help/2976982
Cumulatieve update 2 voor SQL Server 2014 /nl-nl/help/2967546
Cumulatieve update 10 voor SQL Server 2012 SP1 /nl-nl/help/2954099
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
- Laatste cumulatieve update voor SQL Server 2012 SP2
- Meest recente cumulatieve update voor SQL Server 2014
- Laatste cumulatieve update voor SQL Server 2012 SP1
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.