Symptomen
Stel dat u een of meer entiteiten hebt verwijderd in Master Data Services (MDS) voor Microsoft SQL Server 2012 of SQL Server 2014. Wanneer u het beveiligingsmodel probeert te bewerken voor bepaalde groepen of gebruikers in MDS, wordt het volgende foutbericht weergegeven:
Opmerking
Er is een onbekende fout opgetreden.
Opmerking Wanneer u MDS-traceringslogboekregistratie inschakelt en de fout reproduceert, wordt het volgende foutbericht in het traceringslogboek weergegeven:
Opmerking
Er is al een item met dezelfde code toegevoegd.
Oorzaak
Het probleem treedt op omdat de beveiliging op kenmerkniveau van de verwijderde entiteit niet dienovereenkomstig wordt verwijderd.
Oplossing
Het probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server.
Cumulatieve update 1 voor SQL Server 2014 SP1 /nl-nl/help/3067839
Cumulatieve update 6 voor SQL Server 2014 /nl-nl/help/3031047
Cumulatieve update 4 voor SQL Server 2012 SP2 /nl-nl/help/3007556
Cumulatieve update 13 voor SQL Server 2012 SP1 /nl-nl/help/3002044
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
- Meest recente cumulatieve update voor SQL Server 2014 SP1
- Meest recente cumulatieve update voor SQL Server 2014
- Laatste cumulatieve update voor SQL Server 2012 SP2
- Laatste cumulatieve update voor SQL Server 2012 SP1
Tijdelijke oplossing
U kunt dit probleem omzeilen door het bijbehorende kenmerkbeveiligingsniveau te verwijderen of de kenmerken te verwijderen waarnaar wordt verwezen in de groepsbeveiliging. Verwijder vervolgens de entiteit.
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.