Symptomen
Stel dat u de functie Microsoft SQL Server 2012 Service Pack 2 (SP2) of SQL Server 2014 AlwaysOn Availability Groups gebruikt. Wanneer een beschikbaarheidsgroep van de ene naar de andere serverinstantie wordt verplaatst vanwege een failover, wordt het volgende foutbericht in SQL Server ERRORLOG weergegeven op de server waarvan de database van de primaire replica naar een secundaire replica wordt overgeschakeld:
Opmerking
Systeemobjecten kunnen niet worden bijgewerkt in de database '<databasenaam>' omdat deze alleen-lezen is
Oplossing
Dit probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server.
Cumulatieve update 5 voor SQL Server 2014 /nl-nl/help/3011055
Cumulatieve update 3 voor SQL Server 2012 SP2 /nl-nl/help/3002049
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
- Meest recente cumulatieve update voor SQL Server 2014
- Laatste cumulatieve update voor SQL Server 2012 SP2
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.