KB3080209 - FIX: Fout 602 wanneer u een opgeslagen procedure meerdere keren uitvoert in SQL Server 2012 of SQL Server 2014

Van toepassing op
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptomen

Stel dat u Microsoft SQL Server 2012 of SQL Server 2014 gebruikt. Wanneer u herhaaldelijk in één sessie een opgeslagen procedure uitvoert waarmee gegevens uit een tijdelijke tabel worden opgehaald, wordt het volgende foutbericht weergegeven:

Opmerking

Fout: 602, Ernst: 21, Staat: 30.Kan geen vermelding vinden voor tabel of index met partitie-id <partitie-id> in < de databasenaam>. Deze fout kan optreden als een opgeslagen procedure verwijst naar een gevonden tabel of als metagegevens beschadigd zijn. Haal de opgeslagen procedure weg en maak deze opnieuw, of voer DBCC CHECKDB uit.

Opmerking: Dit probleem treedt vaker op bij een systeem met veel CPU's, bijvoorbeeld een computer met 20 CPU's.

Oplossing

Het probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server:

Aanbeveling: Installeer de meest recente cumulatieve update voor SQL Server

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. We raden u aan de meest recente cumulatieve updates voor SQL Server te downloaden en te installeren:

      

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.