Symptomen
Neem als voorbeeld het volgende scenario:
- U maakt een bedrijfsregel waarmee wordt getest op een lege waarde voor een numeriek kenmerk in Microsoft SQL Server 2012 Master Data Services (MDS).
- U slaat de bedrijfsregel op en publiceert deze.
- U opent de entiteit in MDS Explorer en voert de bedrijfsregel uit om de entiteitsleden te valideren.
In dit scenario wordt het volgende foutbericht weergegeven:
Opmerking
8114: Fout bij het converteren van gegevenstype nvarchar naar numeriek. Het aantal transacties na EXECUTE geeft een niet-overeenkomend aantal BEGIN- en COMMIT-instructies aan. Vorige telling = 0, huidige telling = 1.
Opmerking: dit probleem treedt ook op in SQL Server MDS van 2014 waarop CU3 of latere versies zijn toegepast. Wanneer u bijvoorbeeld een bedrijfsregel uitvoert in MDS waarmee wordt gecontroleerd of een datumkenmerk leeg is, wordt het volgende foutbericht weergegeven:
Opmerking
Fout bij het converteren van het gegevenstype nvarchar naar datetime
Oplossing
Het probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server.
Cumulatieve update 6 voor SQL Server 2014 /nl-nl/help/3031047
Cumulatieve update 4 voor SQL Server 2012 SP2 /nl-nl/help/3007556
Cumulatieve update 14 voor SQL Server 2012 SP1 /nl-nl/help/3023636
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
- Meest recente cumulatieve update voor SQL Server 2014
- Laatste cumulatieve update voor SQL Server 2012 SP2
- Laatste cumulatieve update voor SQL Server 2012 SP1
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.