KB2948180 - FIX: Error when you restore full database backup from the secondary in SQL Server 2014

Applies To
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptoms

Assume that you use Microsoft SQL Server 2014. When you try to restore the full database backup that is taken from the secondary, you receive the following error:

Note

Server: Msg 3456, Level 16, State 1, Line 1
Could not redo log record (7699660:807911:68), for transaction ID (7:-1072820627), on page (3:2044928), allocation unit 72057594078167040, database '<cl_support>⁠' (database ID 5). 
Page: LSN = (7699660:489185:317), allocation unit = 6488064, type = 8.
Log: OpCode = 7 (LOP_SET_BITS), context 8 (LCX_GAM), PrevPageLSN: (7699660:766590:822).

Cause

The issue occurs because of a defect in SQL Server 2014.
There may be pages that are missing some updates from before the checkpoint associated with the backup. Because of this, SQL Server only starts page updates from the last completed checkpoint before the backup starts copying pages.

Resolution

The issue was first fixed in the following cumulative update of SQL Server.

Cumulative Update 1 for SQL Server 2014 /en-us/help/2931693

About cumulative updates for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. Check out the latest cumulative updates for SQL Server:

      

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.