KB3073294 - FIX: "Possible schema corruption. Run DBCC CHECKCATALOG" error occurs when you delete column in SQL Server 2014

Applies To
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptoms

Assume that you have a table that has a nonclustered columnstore index in Microsoft SQL Server 2014. When you add a column and then delete the column in the table, you receive the following error messages:

Note

Msg 211, Level 23, State 19, Line 38
Possible schema corruption. Run DBCC CHECKCATALOG.
Msg 0, Level 20, State 0, Line 37
A severe error occurred on the current command. The results, if any, should be discarded.

Msg 682, Level 22, State 153, Line 76
Internal error. Buffer provided to read column value is too small. Run DBCC CHECKDB to check for any corruption.

Resolution

The issue was first fixed in the following cumulative updates of SQL Server:

Recommendation: Install the latest cumulative update for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. We recommend that you download and install the latest cumulative updates for SQL Server:

      

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.