KB2974376 - FIX: Error when you execute a stored procedure that inserts records into temp table the second time in SQL Server 2014

Applies To
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptoms

Assume that you have a stored procedure that could create a temp table and insert records into the table with SET IDENTITY_INSERT ON in Microsoft SQL Server 2014. The table that is created by the procedure has an identity field, and the identity field is indexed. When you execute the procedure the second time, an access violation occurs. Additionally, you receive the following error:

Note

Msg 0, Level 11, State 0, Line 0
A severe error occurred on the current command.  The results, if any, should be discarded.
Msg 0, Level 20, State 0, Line 0
A severe error occurred on the current command.  The results, if any, should be discarded.

Resolution

The issue was first fixed in the following cumulative update of SQL Server.

Cumulative Update 2 for SQL Server 2014 /en-us/help/2967546

About cumulative updates for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. Check out the latest cumulative updates for SQL Server:

      

Workaround

To work around this issue, remove the index on the identity field.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.