KB3094865 - FIX: "The process could not initialize '<Resolver Name>'" error occurs when you use merge publication in SQL Server 2014

Applies To
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptoms

Consider the following scenario:

  • You create a publication of the type Merge Replication (Web Synchronization).
  • You configure this publication to use a Microsoft COM-based resolver for resolving conflicts.
  • You create a subscription for the publication.

In this scenario, the sychronization fails, and you receive the following error message:

Note

Source: Merge Process(Web Sync Client)
Number: -2147198716
Message: The process could not initialize '<Resolver Name>'. Verify that the component is registered correctly.

Resolution

The issue was first fixed in the following cumulative updates of SQL Server:

Recommendation: Install the latest cumulative update for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. We recommend that you download and install the latest cumulative updates for SQL Server:

      

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.