Sintomi
Si supponga di usare In-Memory l'elaborazione delle transazioni online (OTP) in SQL Server 2017 su Windows. Quando si tenta di eseguire il backup di un database contenente tabelle OLTP ottimizzate per la memoria e uno o più contenitori nel filegroup ottimizzato per la memoria archiviato nell'archiviazione BLOB di Microsoft Azure, è possibile notare che l'operazione di backup potrebbe non riuscire con un messaggio di errore simile al seguente:
Nota
- Errore: 3633, gravità: 16, stato: 1.
- Il sistema operativo ha restituito l'errore "2(Il sistema non riesce a trovare il file specificato)". durante il tentativo di 'BackupDataFile::Open' su 'FilePath\FileName.hkckp' a 'fileprod.cpp'(988).
Inoltre, occasionalmente può verificarsi una violazione di accesso.
Risoluzione
Questo problema è stato risolto nel seguente aggiornamento cumulativo per SQL Server:
Aggiornamento cumulativo 2 per SQL Server 2017
Informazioni sugli aggiornamenti cumulativi per SQL Server:
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
Aggiornamento cumulativo più recente per SQL Server 2017
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.