KB4486940 - FIX: L'errore di asserzione si verifica quando si tenta di eseguire il backup di un database in uno spazio su disco limitato in SQL Server 2016 e 2017

Si applica a
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Sintomi

Si supponga di avere installato Microsoft SQL Server 2016 o 2017. Se si prova a eseguire il backup del database in uno spazio su disco limitato, l'operazione di backup potrebbe non riuscire. Inoltre, quando si tenta di annullare l'operazione di backup, può verificarsi un errore di errore di asserzione simile al seguente:

DateTime spid# Asserzione di SQL Server: File: FileName><, line=LineNumber Failed assertion = '0'. Questo errore potrebbe essere correlato al tempo. Se l'errore persiste dopo aver rieseguito l'istruzione, usare DBCC CHECKDB per verificare l'integrità strutturale del database o riavviare il server per assicurarsi che le strutture di dati in memoria non siano danneggiate.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Risoluzione

Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:

Informazioni sugli aggiornamenti cumulativi per SQL Server:

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.