KB4087406 - CORREZIONE: errore 9002 quando non è disponibile spazio su disco sufficiente per la crescita critica del log in SQL Server 2014, 2016 e 2017

Si applica a
SQL Server 2014 Service Pack 2 - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1 SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 on Windows SQL Server 2017 Developer SQL Server 2017 Enterprise SQL Server 2017 Enterprise Core

Sintomi

Quando si eseguono diverse operazioni non di crescita dei file, ad esempio il backup in Microsoft SQL Server 2014, 2016 o 2017, le operazioni potrebbero usare tutto lo spazio su disco e non vi è spazio sufficiente per la crescita critica dei log. Poiché il database non può creare più spazio di log, le modifiche al database e la sincronizzazione con i database secondari non riescono, il ripristino non riesce e il database non può essere portato online. Inoltre, potresti ricevere uno o più dei seguenti messaggi di errore:

  • Nota

    Errore 9002, gravità: 17, stato: 9.
    Il log delle transazioni per il database 'DatabaseName' è pieno a causa di 'AVAILABILITY_REPLICA'

  • Nota

    Avviso 3052: Messaggio 3052, livello 16, stato 1, riga LineNumber
    BACKUP LOG non è stato in grado di registrare gli aggiornamenti per il database 'DatabaseName'.
    I backup del log successivi saranno necessari per far avanzare il punto di backup da 'LSNID1' a 'LSNID2' dopo che lo spazio del log è stato reso disponibile per la registrazione.

  • Nota

    Errore 3314
    Durante l'annullamento di un'operazione registrata nel database 'DatabaseName', si è verificato un errore nell'ID record di log %S_LSN. In genere, l'errore specifico è registrato in precedenza come errore nel servizio Registro eventi di Windows. Ripristinare il database o il file da un backup o ripristinare il database.

Risoluzione

Questa correzione è inclusa nei seguenti aggiornamenti cumulativi per SQL Server:

Aggiornamento cumulativo 1 per SQL Server 2016 SP2

Aggiornamento cumulativo 5 per SQL Server 2017

Aggiornamento cumulativo 8 per SQL Server 2016 SP1

Aggiornamento cumulativo 11 per SQL Server 2014 SP2

Informazioni sugli aggiornamenti cumulativi per SQL Server:

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

Aggiornamento cumulativo più recente per SQL Service 2017

Aggiornamento cumulativo più recente per SQL Server 2016

Aggiornamento cumulativo più recente per SQL Server 2014

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.