Sintomi
Si consideri lo scenario seguente:
- Hai il log shipping di Microsoft SQL Server o il backup/ripristino configurato tra due server.
- Il database potrebbe essere inattivo o avere VLF di piccole dimensioni (ma non è necessario).
- Si eseguono copie di backup del database e quindi si tenta di eseguire il ripristino utilizzando l'opzione standby nel database secondario.
In questo scenario, l'operazione di ripristino potrebbe non riuscire e restituire il messaggio di errore seguente:
Nota
- Errore: 9004, gravità: 21, stato: 1.
- Si è verificato un errore durante l'elaborazione del log per il database database_name. Se possibile, esegui il ripristino da backup. Se non è disponibile un backup, potrebbe essere necessario ricostruire il log.
Dopo questo errore, il database secondario passa in stato di ripristino.
Risoluzione
Questo problema è stato risolto nei seguenti aggiornamenti cumulativi:
- Aggiornamento cumulativo 5 per SQL Server 2017
- Aggiornamento cumulativo 8 per SQL Server 2016 SP1
- Aggiornamento cumulativo 10 per SQL Server 2014 Service Pack 2.
Informazioni sugli aggiornamenti cumulativi per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
Aggiornamento cumulativo più recente per SQL Server 2017
Aggiornamento cumulativo più recente per SQL Server 2016
Aggiornamento cumulativo più recente per SQL Server 2014
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.