KB4469600 - FIX: la replica peer-to-peer non riesce negli SQL Server 2016 e 2017 se il nome host non è maiuscolo

Si applica a
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 on Windows

Sintomi

Si supponga che Microsoft SQL Server 2016 o 2017 sia installato in una macchina virtuale di Azure il cui nome non sia scritto solo in maiuscolo. Dopo aver riavviato il servizio SQL Server, si noterà che la replica peer-to-peer non riesce. Inoltre, è possibile che venga visualizzato un messaggio di errore simile al seguente:

Nota

Non sono stati trovati colleghi per la produzione. Se questo errore si verifica durante l'esecuzione della stored procedure sp_requestpeerresponse, verificare che siano state create sottoscrizioni prima di tentare di chiamare nuovamente la procedura. Se si verifica questo errore in altre circostanze, contatta il servizio di supporto tecnico. (Fonte: MSSQLServer, numero di errore: 20807)

Risoluzione

Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:

Aggiornamento cumulativo 17 per SQL Server 2017
       Aggiornamento cumulativo 8 per SQL Server 2016 SP2
       Aggiornamento cumulativo 12 per SQL Server 2016 SP1

Informazioni sugli aggiornamenti cumulativi per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

Aggiornamento cumulativo più recente per SQL Server 2017
Aggiornamento cumulativo più recente per SQL Server 2016

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.