Sintomi
Si consideri lo scenario seguente:
- Si dispone di un'istanza di Microsoft SQL Server 2017 con una configurazione server collegata a un'altra istanza di SQL Server.
- Un utente senza ignorare il controllo incrociato dei diritti dei criteri locali esegue la prima query del server collegato dopo un riavvio del servizio SQL Server.
In questo scenario, viene eseguita la query iniziale sul server collegato e ogni successiva query sul server collegato da parte di qualsiasi utente restituisce messaggi di errore simili ai seguenti:
Nota
Il provider OLE DB "SQLNCLI11" per il server collegato "server_name" ha restituito un messaggio "Si è verificato un errore correlato alla rete o specifico dell'istanza durante la creazione di una connessione a SQL Server. Il server non è stato trovato o non è accessibile. Verificare se il nome dell'istanza è corretto e se SQL Server è configurato per consentire le connessioni remote. Per altre informazioni, vedere la documentazione online di SQL Server."
Il provider OLE DB "SQLNCLI11" per il server collegato "server_name" ha restituito il messaggio "Il client non è in grado di stabilire la connessione".
Messaggio 21, livello 16, stato 1, riga 0
Crittografia non supportata nel client
Risoluzione
Questo problema è stato risolto nel seguente aggiornamento per SQL Server:
Aggiornamento cumulativo 12 per SQL Server 2017
Informazioni sulle build di SQL Server
Ogni nuova build per SQL Server contiene tutti gli hotfix e le correzioni di sicurezza presenti nella build precedente. È consigliabile installare la build più recente per la versione di SQL Server:
Build più recente per SQL Server 2017
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Riferimenti
Informazioni sulla terminologia standard utilizzata da Microsoft per descrivere gli aggiornamenti software.