Sintomi
Si consideri lo scenario seguente:
- Si usano le tabelle temporali in Microsoft SQL Server 2016 o 2017.
- È possibile partizionare sia la tabella corrente che contiene i dati sia la tabella di cronologia.
- Si tenta di scambiare la partizione più vecchia e dividere la prima partizione per creare una nuova partizione.
In questo scenario, quando si unisce la partizione meno recente, è possibile che venga visualizzato il messaggio di errore seguente. Viene inoltre generato un file di dump della memoria EXCEPTION_ACCESS_VIOLATION.
Nota
- Messaggio 596, livello 21, stato 1, riga LineNumber
- Impossibile continuare l'esecuzione perché la sessione è nello stato di terminazione.
- Messaggio 0, livello 20, stato 0, riga LineNumber
- Si è verificato un errore grave nel comando corrente. I risultati, se presenti, devono essere scartati.
Risoluzione
Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:
Aggiornamento cumulativo 14 per SQL Server 2017
Aggiornamento cumulativo 4 per SQL Server 2016 SP2
Aggiornamento cumulativo 10 per SQL Server 2016 SP1
Informazioni sugli aggiornamenti cumulativi per SQL Server:
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
Aggiornamento cumulativo più recente per SQL Server 2017
Aggiornamento cumulativo più recente per SQL Server 2016
Altre informazioni
Per altre informazioni sul partizionamento con le tabelle temporali, vedere Partizionamento con le tabelle temporali.
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.