Sintomi
Si supponga di usare Management Data Warehouse (MDW) in un'istanza denominata di Microsoft SQL Server 2016 o 2017. Quando si tenta di riconfigurare le impostazioni MDW usando SQL Server Management Studio (SSMS) o eseguendo la stored procedure sp_syscollector_update_collection_set, è possibile che venga visualizzato un messaggio di errore simile al seguente:
Nota
- Messaggio 14684, livello 16, stato 1, procedura ProcedureName, Line LineNumber [Batch Start Line Number]
- Errore rilevato#: 14684, livello: 16, stato: 1, in Procedura: ProcedureName, riga: LineNumber, con messaggio: errore rilevato#: 14262, livello: 16, stato: 1, in Procedura: ProcedureName, riga: LineNumber, con messaggio: Il valore specificato @ServerName (...) non esiste.
Risoluzione
Questo problema è stato risolto nel seguente aggiornamento cumulativo per SQL Server:
Aggiornamento cumulativo 4 per SQL Server 2017
Aggiornamento cumulativo 7 per SQL Server 2016 SP1
Informazioni sugli aggiornamenti cumulativi per SQL Server:
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
Aggiornamento cumulativo più recente per SQL Server 2017
Aggiornamento cumulativo più recente per SQL Server 2016
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.