KB4540901 - FIX: SQL Server potrebbe terminare a causa di conflitti di blocco durante l'elaborazione di messaggi di errore in SQL Server 2016, 2017 e 2019

Si applica a
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 on Windows SQL Server 2019 on Windows SQL Server 2017 Developer on Windows SQL Server 2017 Enterprise Core on Windows SQL Server 2017 Enterprise on Windows SQL Server 2017 Standard on Windows

Sintomi

Si supponga che la maschera dati dinamica sia abilitata in una o più tabelle in Microsoft SQL Server 2016, 2017 o 2019. In rari casi, potrebbe verificarsi un conflitto di blocchi durante l'elaborazione dei messaggi di errore e SQL Server potrebbe terminare in modo imprevisto. Inoltre, nel log degli errori può essere registrata una voce di errore simile alla seguente:

      

DateTime SpidId Dump di overflow dello stack non possibile - Eccezione ExceptionId EXCEPTION_STACK_OVERFLOW in ExceptionAddress
      

DateTime SpidId ex_terminator: possibile terminazione a causa di un'eccezione durante la rimozione dello stack.
      

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".

Risoluzione

Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:

Informazioni sugli aggiornamenti cumulativi per SQL Server:

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

Soluzione alternativa

Per risolvere il problema, è possibile rimuovere tutti i mascheramenti dei dati dalle tabelle.

Riferimenti

Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.