Sintomi
Quando si esegue il backup di una macchina virtuale (VM) con il backup non basato su componenti, si nota che il servizio writer SQL non ignora il backup dei database del gruppo di disponibilità di base Always On in database secondari. Inoltre, è possibile che vengano visualizzati il log degli errori e la traccia del servizio writer SQL simili ai seguenti:
Log degli errori
Errore: 3041, gravità: 16, stato: 1.
BACKUP non è riuscito a completare il comando BACKUP DATABASE myDatabase. Controllare il registro applicazioni di backup per i messaggi dettagliati.
Errore: 3041, gravità: 16, stato: 1.
BACKUP non è riuscito a completare il comando BACKUP DATABASE master. Controllare il registro applicazioni di backup per i messaggi dettagliati.
Errore: 18210, gravità: 16, stato: 1.
BackupVirtualDeviceFile::P repareToFreeze: errore nel dispositivo di backup '{DeviceId}1'. Errore del sistema operativo 995(L'operazione di I/O è stata interrotta a causa della chiusura di un thread o di una richiesta dell'applicazione).
Errore: 3041, gravità: 16, stato: 1.
BACKUP non è riuscito a completare il comando BACKUP DATABASE model. Controllare il registro applicazioni di backup per i messaggi dettagliati.
Errore: 18210, gravità: 16, stato: 1.
BackupVirtualDeviceFile::P repareToFreeze: errore nel dispositivo di backup '{DeviceId}2'. Errore del sistema operativo 995(L'operazione di I/O è stata interrotta a causa della chiusura di un thread o di una richiesta dell'applicazione).
Errore: 3041, gravità: 16, stato: 1.
BACKUP non è stato possibile completare il comando BACKUP DATABASE msdb. Controllare il registro applicazioni di backup per i messaggi dettagliati.
Errore: 18210, gravità: 16, stato: 1.
BackupVirtualDeviceFile::P repareToFreeze: errore nel dispositivo di backup '{DeviceId}3'. Errore del sistema operativo 995(L'operazione di I/O è stata interrotta a causa della chiusura di un thread o di una richiesta dell'applicazione).
Log del servizio writer SQL
Percorso file: ** ANALISI SQLWRITER AVVIATA - ProcessId: #, ContextId: #
FilePath: ** N.B. NON INIZIALIZZATO DAL COSTRUTTORE
Percorso file: ** Ora corrente: #
Percorso file: ** Riga di comando: "CommandLine"
Percorso file: ** Versione prodotto: ProductVersion
FilePath: DoesInstanceSupportRANUUserInstances: Instance MSSQL13. MSSQLSERVER Edition: Standard Edition
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Risoluzione
Il problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:
- Aggiornamento cumulativo 16 per SQL Server 2017
- Aggiornamento cumulativo 7 per SQL Server 2016 Service Pack 2
Informazioni sugli aggiornamenti cumulativi per SQL Server:
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
- Aggiornamento cumulativo più recente per SQL Server 2017
- Aggiornamento cumulativo più recente per SQL Server 2016
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.