KB4040531 - FIX: Fout over schending van beperkingen die wordt geretourneerd door de functie managed_backup.fn_available_backups nadat u cumulatieve update 2 voor SQL Server 2016 SP1 hebt geïnstalleerd

Van toepassing op
SQL Server 2016 Service Pack 1 SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 on Windows (all editions)

Symptomen

Stel dat u SQL Server beheerde back-up gebruikt om back-ups te maken van databases naar Microsoft Azure in Microsoft SQL Server 2016 of 2017. Nadat u cumulatieve update 2 voor SQL Server 2016 SP1 hebt geïnstalleerd om het probleem op te lossen dat wordt beschreven in KB 4014002, wordt er bij het uitvoeren van de beheerde back-upfunctie managed_backup.fn_available_backups een foutbericht van de volgende strekking weergegeven:

Schending van UNIQUE KEY-beperking 'ConstraintName'. Kan geen dubbele sleutel invoegen in object 'TableName'. De dubbele sleutelwaarde is (ID, DateTime, first_lsnValue, DB).

De verklaring is beëindigd.

Oplossing

Dit probleem is opgelost in de volgende cumulatieve updates voor SQL Server:

Cumulatieve update 1 voor SQL Server 2017

Cumulatieve update 5 voor SQL Server 2016 SP1

Over cumulatieve updates voor SQL Server:

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:

Meest recente cumulatieve update voor SQL Server 2017

Meest recente cumulatieve updates voor SQL Server 2016

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in de sectie Van toepassing op.

Meer informatie

Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.