KB4488817 - FIX: FILESTREAM voor de I/O-toegangsfunctie voor bestanden kan niet worden ingeschakeld wanneer u CSV (Cluster Shared Volumes) gebruikt in failoverclusters van SQL Server 2016 en 2017

Van toepassing op
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Symptomen

Stel dat u een failoverclusterexemplaar (FCI) van SQL Server 2016 en 2017 hebt. Als de FCI alleen CSV (Cluster Shared Volumes) heeft voor clusterschijven, wordt mogelijk het volgende foutbericht weergegeven wanneer u probeert de optie FILESTREAM inschakelen voor bestands-I/O-toegang in Microsoft SQL Server Configuration Manager in te schakelen:

Er is een onbekende fout opgetreden bij het toepassen van de FILESTREAM-instellingen. Controleer of de parameters geldig zijn. (0x800710dc)

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.

Oplossing

Dit probleem is opgelost in de volgende cumulatieve updates voor SQL Server:

Over cumulatieve updates voor SQL Server:

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:

Tijdelijke oplossing

U kunt dit probleem op de volgende manieren omzeilen:

  1. Schakel de functie FILESTREAM voor I/O-bestandstoegang in tijdens de installatie van SQL Server.
  2. Voeg tijdelijk een gedeelde schijf en een afhankelijkheid van de schijf toe aan de FCI om de FILESTREAM in te schakelen voor bestands-I/O-toegang. Zodra de functie is toegevoegd, kan de gedeelde schijf worden verwijderd.

Meer informatie

Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.