Symptomen
Stel dat u een DAG-omgeving (Distributed AlwaysOn Availability Group) gebruikt in Microsoft SQL Server 2016 of 2017. Als voor de globale primaire replica een lokale secundaire replica is gedefinieerd en u probeert de gedefinieerde secundaire replica te gebruiken om DAG-SEEDING_MODE te wijzigen, wordt een foutbericht van de volgende strekking weergegeven:
Opmerking
- Msg 41168, Level 16, State 2, Line Line Number
- Er is een fout opgetreden tijdens het openen van een beschikbaarheidsreplica met ID *'ID Number'*in de beschikbaarheidsgroep 'Group Name'. De beschikbaarheidsreplica wordt niet gevonden in de configuratie van de beschikbaarheidsgroep. Controleer of de naam van de beschikbaarheidsgroep en de replica-id voor beschikbaarheid juist zijn en probeer de opdracht opnieuw.
Oplossing
Dit probleem is opgelost in de volgende cumulatieve updates voor SQL Server:
Cumulatieve update 18 voor SQL Server 2017
Cumulatieve update 11 voor SQL Server 2016 SP2
Cumulatieve update 12 voor SQL Server 2016 SP1
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
Meest recente cumulatieve update voor SQL Server 2017
Meest recente cumulatieve update voor SQL Server 2016
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in de sectie Van toepassing op.
Meer informatie
Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.