KB5852300 - FIX: SQL Server 2014 of 2016 loopt vast bij de uitvoering van de opdracht DBCC CLONEDATABASE

Van toepassing op
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1

Symptomen

Wanneer u de opdracht DBCC CLONEDATABASE uitvoert op een exemplaar van Microsoft SQL Server 2014 of 2016, kan SQL Server vastlopen. Bovendien wordt een foutbericht van de volgende strekking in het foutenlogboek van de SQL Server vastgelegd.

Opmerking

  • Fout: 615, ernst: 21, status: 1.
  • Kan database-id niet vinden Database-id, naam <Databasenaam>. De database is mogelijk offline. Wacht een paar minuten en probeer het opnieuw.
  • ex_terminator: Mogelijke beëindiging als gevolg van een uitzondering tijdens het afwikkelen van de stapel.
  • 'dbghelp.dll' versie '4.0.5' gebruiken

Oplossing

Dit probleem is opgelost in de volgende cumulatieve updates voor SQL Server:

Cumulatieve update 2 voor SQL Server 2016 SP1

Cumulatieve update 5 voor SQL Server 2014 SP2

Informatie over cumulatieve updates voor SQL Server

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:

Meest recente cumulatieve update voor SQL Server 2016

Meest recente cumulatieve update voor SQL Server 2014

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in de sectie Van toepassing op.

Meer informatie

Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.