Symptomen
Neem als voorbeeld het volgende scenario:
- U gebruikt Microsoft SQL Server 2016 of 2017 voor uitgever, distributeur en abonnee.
- De Distributiedatabase maakt deel uit van een Availability Group (AG).
- U voegt een nieuwe publicatie toe aan de distributiedatabase in de AG.
- De sortering is ingesteld op BIN of hoofdlettergevoelig.
In deze situatie kan de publicatie mislukken en wordt een foutbericht van de volgende strekking weergegeven:
Fout 4104, niveau 16, status 1, procedurenaam van de procedure, regellijnnummer
De meerdelige id 's.job_id' kan niet worden gebonden.
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.
Oplossing
Dit probleem is opgelost in de volgende cumulatieve updates voor SQL Server:
Over cumulatieve updates voor SQL Server:
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
- Meest recente cumulatieve update voor SQL Server 2017
- Meest recente cumulatieve update voor SQL Server 2016
Meer informatie
Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.