KB4497230 - FIX: Kan niet deelnemen aan de secundaire replica als de database een ter ziele gegane bestandsgroep heeft in SQL Server 2014, 2016 en 2017

Van toepassing op
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Service Pack 2 SQL Server 2016 Service Pack 1 SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 Developer Windows SQL Server 2017 Enterprise Windows SQL Server 2017 Enterprise Core Windows SQL Server 2017 Standard Windows

Symptomen

Neem als voorbeeld het volgende scenario:

  • U hebt een database met een ter ziele gegane bestandsgroep die u probeert toe te voegen aan een Always On-beschikbaarheidsgroep (AG) in Microsoft SQL Server 2014, 2016 en 2017.
  • U kunt de database toevoegen aan de primaire replica en de volledige back-ups en logback-ups herstellen met NORECOVERY op de secundaire replica zonder problemen.

Wanneer u in dit scenario probeert de database toe te voegen aan de beschikbaarheidsgroep op de secundaire replica met ALTER DATABASE <DatabaseName> SET HADR AVAILABILITY GROUP = <AGName> of automatische seeding gebruikt om secundaire replica te configureren, ziet u dat fouten 17207 en 5120 worden gerapporteerd voor het gegevensbestand in de ter ziele gegane bestandsgroep:

## spid## Database 'Name' opstarten.

## spid## Fout: 17207, ernst: 16, status: 1.

## spid## FileMgr::StartSecondaryDataFiles: Besturingssysteemfout 2(Het systeem kan het opgegeven bestand niet vinden.) trad op tijdens het maken of openen van het bestand 'FilePath'. Stel de fout in het besturingssysteem vast en corrigeer deze en probeer de bewerking opnieuw.

## spid## Fout: 5120, ernst: 16, status: 5.

## spid## Kan het fysieke bestand 'FilePath' niet openen. Besturingssysteemfout 2: '2(Het systeem kan het opgegeven bestand niet vinden.)'.

U zult ook zien dat de database in de modus Niet synchroniseren/herstellen in behandeling gaat op de secundaire replica nadat de opdracht ALTER DATABASE is uitgevoerd.

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.

Oplossing

Dit probleem is opgelost in de volgende cumulatieve updates voor SQL Server:

Over cumulatieve updates voor SQL Server:

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:

Meer informatie

Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.