KB2717239 - CORRECTIF : erreur « Une erreur s’est produite lors de l’enregistrement de la vue d’abonnement » lors de la création d’une vue d’abonnement par rapport à une hiérarchie dérivée récursive dans SQL Server 2012 Master Data Services

S’applique à
SQL Server 2012 Business Intelligence SQL Server 2012 Developer SQL Server 2012 Enterprise

Microsoft distribue les correctifs Microsoft SQL Server 2012 sous la forme d’un fichier téléchargeable. Étant donné que les correctifs sont cumulatifs, chaque nouvelle version contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif de SQL Server 2012.

Symptômes

Prenons le scénario suivant :

  • Vous disposez d’une hiérarchie dérivée récursive qui comporte un ou plusieurs niveaux non récursifs sous la relation récursive dans SQL Server 2012 Master Data Services.
  • Vous créez une vue d’abonnement par rapport à la hiérarchie dérivée récursive.

Dans ce scénario, le comportement de création d’affichage échoue. En outre, le message d’erreur suivant s’affiche :

Remarque

Une erreur s’est produite lors de l’enregistrement de la vue de l’abonnement

        
      

Résolution

Informations sur les mises à jour cumulatives

SQL Server 2012

Le correctif de ce problème a d’abord été publié dans la mise à jour cumulative 2 pour SQL Server 2012 Service Pack RTM. Pour plus d’informations sur ce package de mise à jour cumulative, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2703275 Package de mise à jour cumulative 2 pour SQL Server 2012Remarque Étant donné que les builds sont cumulatives, chaque nouvelle version de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2692828 Les builds de SQL Server 2012 publiées après la publication des correctifs SQL Server 2012 de Microsoft SQL Server 2012 sont créées pour des Service Packs SQL Server spécifiques. Vous devez appliquer un correctif logiciel SQL Server 2012 Service Pack RTM à une installation de SQL Server 2012 Service Pack RTM. Par défaut, tout correctif logiciel fourni dans un Service Pack SQL Server est inclus dans le Service Pack SQL Server suivant.

Remarque : Ce correctif pour le problème est inclus dans SQL Server 2012 Service Pack 1.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Informations supplémentaires

Pour plus d’informations sur les hiérarchies récursives (Master Data Services), consultez le site web Microsoft à l’adresse suivante :

Informations générales sur les hiérarchies récursives (Master Data Services)