Symptômes
Lorsque vous utilisez la fonction de réplication dans Microsoft SQL Server 2012 ou SQL Server 2014, l’agent de lecture du journal d’activité peut échouer par intermittence. En outre, lʼun des messages dʼerreur suivants sʼaffiche dans le journal des erreurs de SQL Server :
Erreur 1
Remarque
<
Date><Heure><SPID (SPID)> Image de la pile envoyée à <DiskLocation>
<
Date><Heure><SPID (SPID)> * *******************************************************************************
<
Date><Heure><SPID (SPID)> *
<
Date><Heure><SPID (SPID)> * COMMENCER LE VIDAGE DE LA PILE :
<
Date><Heure><SPID (SPID)><* SPID Date><et heure><>
<
Date><Heure><SPID (SPID)> *
<
Date><Heure><SPID (SPID)> * Emplacement : replicat.cpp :2746
<
Date><Heure><SPID (SPID)> * Expression : pRowset
<
Date><Heure><SPID (SPID)> * SPID : <SPID>
<
Date><Heure><SPID (SPID)> * ID du processus : <ProcessID>
<
Date><Heure><SPID (SPID)> *
<
Date><Heure><SPID (SPID)> * Mémoire tampon d’entrée 109 octets -
<
Date><Heure><SPID (SPID)> * 16 00 00 00 12 00 00 00 02 00 00 00 00 00 00 00 00 00
<
Date><Heure><SPID (SPID)> * s p _ r e p 01 00 00 00 0b 00 73 00 70 00 5f 00 72 00 65 00 70 00
<
Date><Heure><SPID (SPID)> * l c m d s & ô 6c 00 63 00 6d 00 64 00 73 00 00 00 00 00 00 26 04 04 f4
<
Date><Heure><SPID (SPID)> * & & ÿ 01 00 00 00 00 26 04 04 00 00 00 00 00 00 00 26 04 04 ff
<
Date><Heure><SPID (SPID)> * ÿÿÿ ¥ & ff ff ff 00 00 a5 0a 00 00 00 00 00 00 26 04 04 00 00 00 00
<
Date><Heure><SPID (SPID)> * & & ¡ 00 00 00 26 04 04 00 00 00 00 00 00 00 26 04 04 20 A1 07
<
Date><Heure><SPID (SPID)> * 00
Erreur 2
Remarque
<Date><Heure><Erreur SPID> : 5243, Gravité : 22, État : 7.
<SPID> Date><Heure>< Une incohérence a été détectée lors d’une opération interne. Contactez le support technique.
<Date><Heure><SPID> ex_raise2 : Exception levée, majeur=52, mineur=43, état=7, gravité=22, tentative de création d’un vidage de symptôme
<Date><Heure><SPID> **Dump thread - spid = 0, EC = 0x000000297EC97DE0
<Date><Heure><SPID> ***Vidage de pile envoyé à <DiskLocation>
<Date><Heure><SPID> * *******************************************************************************
<SPID Date><et heure><> *
<Date><Heure><SPID> * DÉBUT DU VIDAGE DE LA PILE :
<Date><Heure><SPID> * <Date><Heure><SPID>
<SPID Date><et heure><> *
<SPID> Date><Heure>< * ex_raise2 : Exception levée, majeure = 52, mineure = 43, état = 7, gravité = 22
<SPID Date><et heure><> *
<Date><Heure><SPID> * Mémoire tampon d’entrée 109 octets -
<Date><Heure><SPID> * 16 00 00 00 00 12 00 00 00 02 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0
<Date><Heure><SPID> * s p _ r e p 01 00 00 00 0b 00 73 00 70 00 5f 00 72 00 65 00 70 00
<Date><Heure><SPID> * l c m d s & ô 6c 00 63 00 6d 00 64 00 73 00 00 00 00 00 00 00 26 04 04 F4
<Date><Heure><SPID> * & & ÿ 01 00 00 00 00 26 04 04 00 00 00 00 00 00 00 00 26 04 04 ff
<Date><Heure><SPID> * ÿÿÿ ¥ & ff ff ff 00 00 a5 0a 00 00 00 00 00 00 26 04 04 00 00 00 00
<Date><Heure><SPID> * & & ¡ 00 00 00 26 04 04 00 00 00 00 00 00 00 26 04 04 20 A1 07
<Date><Heure><SPID> * 00
Cause
Ce problème se produit lorsque le même article est publié dans plus d’une publication transactionnelle, ou que le même article fait partie de la CDC et de la publication transactionnelle.
Résolution
Informations sur les mises à jour cumulatives
Ce problème a été résolu dans la mise à jour cumulative de SQL Server suivante :
- Mise à jour cumulative 13 pour SQL Server 2014
- Mise à jour cumulative 2 pour SQL Server 2012 Service Pack 3
- Mise à jour cumulative 5 pour SQL Server 2014 SP1
- Mise à jour cumulative 12 pour SQL Server 2012 SP2
Recommandation : Installer la dernière mise à jour cumulative pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Nous vous recommandons de télécharger et d’installer les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2014
- Dernière mise à jour cumulative pour SQL Server 2012 SP3
- Dernière mise à jour cumulative pour SQL Server 2014 SP1
- Dernière mise à jour cumulative pour SQL Server 2012 SP2
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».