Symptômes
Supposons que vous utilisez la fonctionnalité Groupes de disponibilité Microsoft SQL Server 2012 Service Pack 2 (SP2) ou SQL Server 2014 AlwaysOn. Lorsqu’un groupe de disponibilité est déplacé d’un instance serveur à un autre instance en raison d’une occurrence de basculement, le message d’erreur suivant s’affiche dans SQL Server journal des erreurs sur le serveur dont la base de données bascule du réplica principal vers un réplica secondaire :
Remarque
Les objets système n’ont pas pu être mis à jour dans la base de données «<Database name> » car elle est en lecture seule
Résolution
Ce problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.
Mise à jour cumulative 5 pour SQL Server 2014 /en-us/help/3011055
Mise à jour cumulative 3 pour SQL Server 2012 SP2 /en-us/help/3002049
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2014
- Dernière mise à jour cumulative pour SQL Server 2012 SP2
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».