CORRECTIF : altération des données dans l’index cluster lors de l’exécution d’une reconstruction d’index en ligne dans SQL Server 2012 ou SQL Server 2014

S’applique à
SQL Server 2012 Enterprise SQL Server 2012 Enterprise SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use)

Symptômes

La reconstruction d’index en ligne peut entraîner une altération de l’index ou une perte de données lorsqu’elle est utilisée avec des requêtes simultanées qui modifient de nombreuses lignes dans Microsoft SQL Server 2012 ou Microsoft SQL Server 2014. Par exemple, une réplication met à jour de nombreuses lignes sur une table lorsque la génération d’index en ligne s’exécute simultanément sur la même table.

Ce problème se produit lorsque les conditions suivantes sont remplies :

  • La requête de génération d’index en ligne s’exécute en mode parallèle.
  • Une erreur de blocage et une erreur irrécupérable telle que « lockout timeout » se produisent dans un ordre spécifique.

Remarque Pour contourner ce problème, exécutez la génération d’index en ligne en mode série (DOP = 1).

Résolution

Informations sur les mises à jour cumulatives

Le problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.

Mise à jour cumulative 11 pour SQL Server 2012 SP1 /en-us/help/2975396

Mise à jour cumulative 1 pour SQL Server 2012 SP2 /en-us/help/2976982

Mise à jour cumulative 2 pour SQL Server 2014 /en-us/help/2967546

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

      

Informations sur le correctif logiciel SQL Server 2012 Un correctif logiciel pris en charge est disponible auprès de Microsoft. Toutefois, il est conçu uniquement pour corriger le problème décrit dans cet article. N’appliquez ce correctif qu’aux systèmes sur lesquels vous rencontrez ce problème.

Si le correctif logiciel est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, demandez le correctif logiciel auprès du Support technique et Service clientèle Microsoft.

Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support s'appliqueront aux autres questions et problèmes du support non directement liés au correctif logiciel en question. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :

/contactus/ ?ws=support Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif logiciel est disponible. Si votre langue n'est pas répertoriée, cela signifie qu'aucun correctif logiciel n'est disponible pour cette langue.

Remarque Après l’application du correctif logiciel, les progress_report_online_index_operation d’événements étendus incluront en outre les détails de l’erreur dans le champ de données error_number ajouté à l’événement. Ce champ peut être utilisé pour identifier les échecs internes au cours de l’opération d’indexation en ligne.

Exigence de redémarrageIl n’est pas obligatoire de redémarrer l’ordinateur après avoir appliqué ce correctif logiciel.

Informations sur le remplacement des correctifs logicielsCe correctif logiciel ne remplace pas un correctif logiciel déjà publié.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».